Facing issues with DISARMING ON LANDING

Please see I am re-posting my problem as I did not receive any solution for my problem.

I am using pixhawk cube 2.1 with firmware 3.6.9. My hexacopter is unable to disarm after landing.
It did not disarm after landing when switched to RTL. In this case, my frame flipped after landing and pixhawk did not detect any crash and motors were still running.

I tried to land using Loiter, again it did not disarm the motors after landing. In this case, the crash was detected and motors were disarmed.

here is the link for the log from the crash after landing. log

please follow the link to understand my full problem https://discuss.ardupilot.org/t/facing-problems-with-disarming-on-landing

Please help me figure out why this is happening?

hi Zuber
from your log its seems that your copter not disarming motors after landing and suddenly increase motor throttle

I’m not 100% sure what is the problem but if you have tall landing gear you can set GND_ALT_OFFSET from parameters but VERY VERY BE CAREFUL and test your drone in a safe place to don’t destroy it.
also you can setup emergency motor stop to prevent damage to your motors and propellers when facing problems like this.

1 Like

also i have this problem when i land in wet lawn with air temperature between 35 - 45 centigrade degree.

Well yeah the landing gears are a little tall but i have flown my other frame with same configuration and I never had this trouble before.
I am flying my drone at dry land with surrounding temperature of 43 degrees but i don’t think that that’s the case here, i have conducted several flights with other frames but never had any problem with the disarming on landing.

Are you using GPS blend by any chance?

You may try to set GND_EFFECT_COMP parameter to “1”.
http://ardupilot.org/copter/docs/ground-effect-compensation.html
Hope this helps

1 Like

No, i did not use GPS blend.

I’m not sure about what happened in landing but here are some tips to avoid crashes.
'Upon reaching the ground the copter will automatically shut-down the motors and disarm the copter if the pilot’s throttle is at minimum. ’ http://ardupilot.org/copter/docs/land-mode.html

Also I use a separate channel (i.e. RC8 opt)in ‘Motor Emergency Stop’ mode. Once activated it override other channel inputs and all motors stops immediately.

1 Like

Zuber,

Try decreasing the LAND_SPEED parameter from its default of 50cm/s to 40cm/s. This way it will slow down more just prior to landing.

Also try configuring the WP_NAVALT_MIN parameter from its default to something like one or two meters. This way the copter will stop trying to fly to the exact final position during the final descent before landing. If the copter is moving sideways when it touches down, it still thinks it is flying and may spin up the motors to fight against the landing gear holding on the ground - this can cause it to tip over.

Paul

2 Likes

I will assign the emergency switch in the worst case scenario.
Thanks for the suggestion @Nord_RED

@flyingw
Thanks for the suggestion, This might actually be helpful.

But my previous flights with the same pixhawk did not give me these troubles but all of a sudden pixhawk became unreliable. Don’t know what triggered this behaviour.

I had the same type of issue some years ago, and finally discovered that the rangefinder was on « enabled », despite the fact that i didnt had one.
It caused the copter to not detect the landing.
Disabling the rangefinder solved the problem.
Hope this will help,
Julien from Corvus Monitoring.

1 Like

I also had/have similar problems, they occurs now randomly. Here is thread which has pretty similar symptoms desribed
https://discuss.ardupilot.org/t/why-quad-doesnt-want-to-disarm-after-landing-happened-two-times-now-arducopter-3-6-7

1 Like