F7 AIO -Autotune

Have Holybro F7 in quad, loaded with latest relevant ardupilot firmware.
Is there a way of invoking autotune similar to px4?

There’s this covering pretty much everything:
and this related to just running Autotune:

It’s the same as any Arducopter capable FC.

Thanks. There are 6 channels for servos. As example ch6 can be assigned to all sorts of things in the pull down in mission planners extended tuning, but no option for autotune. Channel 7 and 8 as auxiliaries are greyed out. Appears as though the F7 has no auxillary channels. Ch 7 and 8 is where the autotune option exists for the px4 in extended tuning. That is how I tuned using my pixhawk.
No auxillary ch, no autotune in F7. If I am wrong I welcome suggestions unless the auxillaries are hiding.

Hopefully solved. Enter “rc#” in the full parameter list and enter 17 for autotune. Save and reboot. Calibrate channel as per normal instruction.

The extended tuning display for F7 ch7 and 8 are greyed out so they cannot accept any input. Why, don’t know.

Or set AutoTune as a flight mode. It doesn’t have to be a Chanel option. .Not sure what you mean by auxiliary channels. And actually you can get 8 PWM channels out of that FC if desired.

If options are greyed out it’s usually a result of the Ardupilot firmware version vs the Mission Planner version. Mission Planner often trails updates in Ardupilot. If you are only seeing chan 7&8 in Mission Planner then you should update Mission planner. Then it might look like this:

1 Like

Thanks for that. The aux channels are mentioned in Autotune wiki, setup before flying, point 2.
I am just learning the art so the curve has been quite steep. This is my second drone build and this time using the F7 aio plus 4in1 esc. Yes with a 4 in 1. It is so compact and light. Need to solder. RTL function is useful at my experience level.
Will update software shortly.

Aux switches that can be assigned to input channels. But no matter it sounds like you have it figured out.

The F7 AIO is a nice board, I have one in a Plane.

Updated the F7 to latest firmware using MP firmware update. It loaded and confirmed the version was v3.6.10 (1c04a91e).
However after reboot the telemetry has stopped working. On investigation of the serial ports in full parameter list, the port options for all serial ports have vanished. Presume that is why the telemetry stopped working. Any suggestions?

I been getting disappearing options as well but on the zero update to 4.0 and see it it works.

Could you please explain what update (revision)?
The old hex file which was in the official Repository for coptor F7 is (3.7 dev) worked, which fortunately I still have on hdd. The new 3.6.10 does not either for the hex or apj. If I load the old 3.7 dev all works fine for the F7 aio. However neither of the 3.6.10 works. The serial options have gone. That suggests something changed at the firmware level. We can only raise these issues.

Yes the 3.6.10 dosent support the inverted signal that Frsky s-port need to give you the tellemetry values

We have to wait the 3.7 to be stable

Thanks. Why include 3.6.10 in the official F7 repository? The 3.7 dev worked and we took a step back if the 3.6.10 does not.
I am not entirely sure that it isn’t included, is it possible the configurators eg Mission Planner and others are screening out this option selection. Maybe MP needs to revised for the F7 using 3.6.10.