Extreme voltage drop even under moderate load

I’ve got an F450 based drone with a Pixhawk 1, ArduCopter 4.1.5, and an attached Raspberry Pi that can execute autonomous missions in guided mode. I’m using the default voltage and current module that comes with the Pixhawk. It was calibrated under load and should measure the correct voltage.

I often have problems regarding battery failsafes due to a large voltage drop under load. See e.g. this log of my last hover flight.

I realize voltage drops under load are normal, but they shouldn’t be that big, should they? Also, the shouldn’t constantly trigger the default failsafe settings of ArduPilot.

I tried the setup with the following three batteries:

All batteries yielded the same results.

My build data:

  • Readytosky 2212 motors with 920 kv
  • 10x4.5 propellers
  • 3s batteries
  • Readytosky 30A SimonK ESCs
  • Overall weight w/o battery around 1.7kg

Thanks in advance

p.s. This thread says that there is the value Bat.Volt, which contains the directly measured voltage and Bat.VoltR, which tries to clean drops due to throttle increase. Could it be I’m just regarding the wrong value here, or would that hide an underlying problem?

I assume you had a look at this?
https://ardupilot.org/copter/docs/failsafe-battery.html#advanced-settings
The BATT_LOW_TIMER setting may help you with this issue.

If that doesn’t help it is a known limitation of current measurement using a resistor to measure voltage drop caused by current. - Most regular PM are based on that technology.

If you keep having those issues despite changing above mentioned settings, you might want to consider a PM that uses a HAL sensor instead. Those don’t have this sudden voltage drop issue.
One such supplier is Mauch electronics.

→ I just had a look at your log and the batteries: They shouldn’t cause such voltage drop at just 20A.
Are you sure the current settings for your MP are correct?
…I’ve just seen some specs indicating each motor may pull close to 30A. (Which is what I had with similar motors) If that is the case than you might actually draw something like 60A in hover and over 100A in a fast burst.
What size props are you using?

Check your wires, if there is a spot with high resistance you will get these symptoms

Right, I forgot about the propellers, sorry. I added them to my original post.

I calibrated voltage divider and amperes per volt again, this time more thoroughly. I noticed that over time, after I set working values, my measured values and the values in mission planner start to drift apart. Also, my “Amperes per volt” value is currently at 200, is this normal? Btw., I calibrated like this.

I don’t think the motors draw 30A each. At half throttle I measure around 10-15 A from the battery altogether using an ampere meter.

This seems to conclude one of the first things I learned. When you build or drone, be ready to pay a lot of money for quality components or forget about it. Having said that, I’ll invest in a Mauch sensor setup.

However, I’m still interested in fixing my “current” current sensor, so if you have any ideas about that, I’d be happy to hear them.

Thanks so far.

Good Idea checking the wires, why didn’t I think of that! It’s the first thing I should have done…

Unfortunately they’re fine. I measured both plus and minus from the battery plug through the power module to the soldering point on my distribution board and got readings below 1 ohm on each.

@Janis_Blank
I think what Lucas is trying to say is “Is there any part of the wiring that is not rated for those high currents?”
You will know if that is the case if you fly your drone briefly and then touch all the wiring and connectors checking for any hot spots.
Warm=OK
Hot=Bad

I still think the current usage is way higher than indicated by MP. This explains also your very high voltage divider for the amps.
Unfortunately the manufacturer of your motors doesn’t appear to be supplying detailed specifications for your motors. But have found reference saying hover is around 15A (depending on propeller). So 4 motors at 15A you would expect around 60A.

Calibrate the voltage divider at a low voltage, like 9.0 or 10.0 volts in your case.

Here’s how to adjust you’re Amps Per Volt

  • Plug in a fresh battery and do a hover flight for 5 minutes or until you’ve used a signifcant amount of battery capacity
  • Immediately unplug the battery and charge it, note how many mah’s it took to charge. Let’s say that was 1,500 mah
  • Download your log and look at maximum CurrTot. Let’s say it was 1,300 mah
  • Get your existing BATT_AMP_PERVOLT setting from Mission Planner
  • NEW_AMPS_PER_VOLT = OLD_AMPS_PER_VOLT * CHARGED_MAH / LOGGED_MAH
    With my example numbers, you’d get
    NEW_AMPS_PER_VOLT = 17 * 1,500 / 1,300 = 19.61
  • Set the new value in the BATT_AMP_PERVOLT parameter and save to your copter
  • Fly to check, repeat until you’re happy the new value gives consistent readings

Or you can try this:
Easy current calibration-small.pdf (665.3 KB)

I don’t think so. I have 12AWG from the battery to the distribution board. The distribution board is the one integrated in the bottom plate of almost every F450 frame. The soldering spots between battery in and the ESC connections are also fine.

Thanks, that sounds good. I’ll try to get the components and give it a try.

It’s almost quitting time and I can’t think straight anymore, so there is problably an easy answer, but:
If the bulb is operated at 12 volts and generates 60 watts, then it must draw 5 amperes. Why does the author enter 12.6V and 9.5A? I don’t know if I can quickly come up with this bulb and would like to use a 10 ohms load resistor instead, so i need to know the idea behind it.

For what it’s worth, I use a 2200 mAh battery with one 2212 1100Kv motor and a 9" prop on a fixed-wing.

Based on the SunnySky “X” motor of equivalent size, in your configuration I’d expect something like 15A per motor at full throttle.

Edit: I found what appears to be a manufacturer datasheet at https://www.simcoe-diy.ca/product-page/two-readytosky-2212-920kv-cw-ccw-brushless-motor where it shows ~10A at full throttle on 3s with a 10x4.5 prop.

@Janis_Blank
It’s not just a 60W light bulb. It is 60+55W = 115W (low and high beam on a car).
The 12.6V is your battery voltage when using a 3S LiPo battery when fully charged.

If you use a 10 Ohm resistor all you getting is 1.26A using a 3S battery. - You would also need a rather powerful resistor in order to handle the heat that’s being created.
If you look at the current calibration instructions you will find that you need at least 5A for a reasonable calibration. Anything less and it’s fairly useless.

@cbf123
Thanks for providing some reference information. It is roughly in the range I would expect to see for such motors.
May I ask what flight time do you get ?

@Janis_Blank
You don’t have to do the calibration. But it would be very beneficial knowing what we are dealing with here in regards to current, rather than guessing.
If you prefer we can change / check a few settings and see how that goes ?
But I suspect you will only get about 4-6 min. flight time out of your drone.
So not sure if that is the time it takes before you get the fail-safe triggered?

This is a good starting point if you simply want to change a few settings and see how that affects your problem:
https://ardupilot.org/copter/docs/current-limiting-and-voltage-scaling.html

I’m using it on fixed-wing so it’s not directly comparable, but I can easy get 15min of lazy flight.

Thanks, I found that too. However, nobody seems to know the maximum load of these motors (most sources only allow 11.1V). Even the support at Readytosky didn’t seem to know when I wrote them. Trying a 4s battery would also be an option, but I have been hesitant so far with these motors.

So it is getting close to what I’ve expected. Each motor 10A x4 =40Amps.

It’s up to you if you want to the calibration so we actually have good values to work with or if you just want to take a gamble and try a few different settings?
…But some of those settings won’t do much if the current and voltage measurement is incorrect.

I wouldn’t go with the 4S battery option as it may burn out those motors and perhaps the ESC’s as well.

…viel Spass.

I’m not the gambler type, so I invested in a new drone setup with tested 4s compatible motors (https://www.premium-modellbau.de/holybro-x500-v2-arf-set-quadcopter-30125).
I also invested in a Mauch power monitor (this and this) since I don’t trust the stock pixhawk monitor a bit.
The voltage drop is down to 1 to 1.5 volts under load which is, I guess, normal. I also tried the Mauch power monitor on my old setup, but I had the same voltage drop problematic as before.
I wish I could end with a better solution to my original problem than just buying new stuff, but sometimes that’s the solution. Thanks for all your help!

1 Like