Extended Tuning screen in APM Planner

My extended tuning screen doesn’t seem to work now that I’ve updated to rc-4. All the attitude and rate PIDs are now 0. Is there a beta Planner out that works?


this version should work http://firmware.ardupilot.org/Tools/APMPlanner/beta/ 2.0.23-rc4

It was updated to the new naming of the PIDS recently

1 Like

Wonderful. Thank you!

PS: it auto detects which version you have 3.3/3.4-rc1/3.4-rc2 let me know if there is any issue with that

I installed the beta and it won’t read parameters. The Full parameter list is bank and the Extended tab won’t load the UI at all.

but you are connected?

Strange I just ran up the same build and connected as expected. Can you post the apmlog_XXX.txt file for today ~/apmplanner2 in your home dir

Yes, I can see the hud move. Just can’t get params. reverting to the stable app and all is well. apmlog_20160912.txt (124.8 KB)

Slightly anecdotal but I have a pixracer here that I just tested with using MP and it’s ok. I will try now with AP Planner.

you should connect to the device cu.usbmodem1 not tty. as that is for monitoring of the port.

I just tried and the only way I can get it not to load the Extended Tuning Screen was if I connected first as Rover than disconnected. Then flashed AC3.4-rc4.

The fix was to flash AC3.4 then restart Pixhawk and APM plAnner 2.0 and then it worked as expected. It doesn’t switch between vehicles of different types and same sys_id well.

OK, that worked. Not very intuitive, however. I would have never known the difference.

Ok, I’m going to close this. If there’s a need for an enhancement to AP Planner, I guess raising an issue in the APPlanner issues list would be best. https://github.com/ArduPilot/apm_planner/issues

In Qt5.4.2 the serial port abstraction did just that and hid that detail. Since then 5.5+ it’s been shown but you needed to build Qt from source to see that. now builds are based on Qt5.6.1 everybody see it. I’ll add small fix, since it really is confusing…

(Little detail. tty.port doesn’t exist on linux builds and is why the modem manager locks the port and interferes with APM Planner 2.0, on BSD that doesn’t happen due to this tty. for listening and cu. for actual data flow on the ports)

Posts should not be closed but marked solved in general. ‘Auto Close’ maybe after a year might be good idea, but close in such a short time is just really for posts that are going off-topic or people are being out of order on the thread.

I also had the same problem and downloading the 2.0.27-rc1_osx.dmg version I solved the problem with both pixhawk 2.4.8 and with Holiybro pixfalcon