ESC RPM check not allowing takeoff

To clarify, I can see the ESC RPM while connected via USB. But my discussion with @andyp1per leads me to believe that if the tkoff_rpm_min cannot see my bdshot RPM, then neither can the harmonic notch.

I will attempt to revert to 4.4.4 with the same params and see if I still have 6 channels reporting back bdshot RPM on the FMU. But if harmonic notch isn’t actually utilizing the live RPM data, I may be in trouble.

They should not be related. The takeoff issue is a bug that I have just replicated. The harmonic notch should have no issues.

1 Like

My apologies, poor assumption on my part. Thank you for your help!

I reverted back to 4.4.4, and as you have told me, bdshot does in fact work on 6 channels. The tkoff_rpm_min setting seemed to work as well!

What improvements have been made in 4.5.0-beta2 that could help performance with my Pixhawk 6C hexacopter? Or do you recommend staying with 4.4.4 for the meantime?

I was able to find it on Github’s release notes. The extra EKF variance filter seemed to be helping, as I used to see lane changes frequently and with the beta firmware I saw fewer. Please do let me know if you or someone is able to patch the beta firmware, I’d love to utilize it!


You have the intermediate parameter files I provided, I advise you to reset to default parameters with 4.4.4 and do the configuration from scratch. You now have done some changes that are not necessary (RPM_* and other stuff) and those will go away by doing this.

With the intermediate .param files it is very easy to redo the entire process. And post the annotated .param files with your comments on why you changed each parameter.

Once the bug is fixed in 4.5.0 you can update the FW without having to re-do the configuration.

Found it:

2 Likes (220.3 KB) notice the new file 40

The fix is in 4.5beta3 which has just been released - so if you could try that and verify I would be grateful. This might also explain your notch problems.

I uploaded, then went through all my params again using suggested changes from @amilcarlucas as well. The bug is fixed! I set the check at 500 RPM, and takeoff was not blocked. My post filter graph is also looking a little better.

One odd thing to note: my pitch was inverted after setting params back to default and rewriting them again. Perhaps I had it inverted before in params and forgot about it.

As final advice, can you point to good general practices for harmonic notch setup/tuning? I have it set up according to this file now:
16_notch_filter_setup.param (5.0 KB)

Resulted in this graph:

I have seen the general recommendations for notch filters, but uncertain on how many my autopilot can support, better to use two notches/double-notch, how many harmonics, better on 1 or both IMUs, too much filtering…?

Thank you so much for your time, it’s been great learning from both of you!

1 Like

Post a .bin log file. And post the rest of the .param files once you have them.

Absolutely. Here they are!

1 Like

Nice work. Just change INS_HNTCH_HMNCS to 3 to kill that nasty second harmonic.
And you can now proceed to the magfit flight.
Post a .bin file of that one as well and keep on updating and posting the intermediate .param files

1 Like

I have changed that parameter as you said, and am preparing for the magfit flight. Thank you very much for continuing on the path with me.

I have a problem with the Lua scripts. I have followed the directions from How to methodically tune (almost) any multicopter using ArduCopter 4.4.x and Scripted MagFit flightpath generation, but I am getting these errors in my message display after putting the scripts on the microSD card. I have tried re-downloading the scripts as well with the same result.
Screenshot 2024-03-14 161124

4.5.0-beta3, here’s my complete params:
complete params.param (19.2 KB)

Scripts were both placed into the APM/scripts folder, and rc9=300 (momentary button) for waypoint advancing. But the new magfit parameters do not show up for me.

The script isn’t running. The file isn’t downloaded (or uploaded to the autopilot) properly. I just double checked, and it downloads fine for me in a Chromium based browser with a single click on the attachment link.

1 Like

Interesting. I downloaded the two scripts ( copter-magfit-helper.lua and advance-wp.lua) from Google Chrome by single clicking each one. I put the Pixhawk 6C micro SD card into my computer, and did ctrl-c on the two scripts, and ctrl-v into SDHC(D:)\APM\scripts
Any help on what could be going wrong would be great!

I don’t really know what to tell you. The file on your autopilot is somehow incomplete. I just downloaded a copy from the same link you used and tested it. It ran fine.

Thanks @Yuri_Rage , you were right. After several methods of copying/pasting, it worked when I copied them one at a time into the folder. Not sure how they corrupted each other when copied simultaneously, but it’s not giving me the error messages anymore.

I’m excited to test out the magfit script tomorrow! I’ll continue reporting here how things go as you’ve requested @amilcarlucas

Glad you got it sorted. I can’t really fix that sort of thing!

1 Like

Hello again. Weather this week has been great so I’ve been moving on to more of the flights.

I received new (stiffer) propellers, and did the initial flight and harmonic notch tune flight again. The propellers sound much better, but vibes still seem to be about the same. Do these vibes look bad to you? (APC 2 harmonics.BIN - Google Drive) I do not have time now to redesign the copter, so unless you know of smaller things that may help, I may have to live with this vibration. It is much better than last season already!

I performed the scripted magfit flights - unfortunately I do not have current monitoring, as my power routes through my ESC and not my PM07 power module. Any suggestions there for having motor compensation actually work? I have included the auto-generated param file, as well as the magfit flight bin/log file - Bin files - Google Drive

I am going to continue on with evaluating the aircraft tune, and probably autotune today. But I can go back and make changes on prior steps per your advisement. Thank you!

Hi @peterscache12,

The vibration levels are a bit high but still acceptable I think. The vehicle isn’t moving around much so it’s hard to be sure what it will be like during more dynamic flights but at least for what we see in this log it’s in the acceptable range which is less than 30m/s/s in the Z-axis and less than about 15m/s/s in the X and Y.