Esc calibration issues with 3.6.6

m trying to calibrate esc under arducopter 3.6.6, I have the following motors t920kv with air gear 20a esc, after many trials the issue is still the same, I’ve also change the servo function without a positive result. I’ve tested the x2.1 with same firmware with hobbywing 35a esc blheli/oneshot with dys 2400kv motors without any issue. How i can solve it?

@Dave84 Hello David.

To answer your question:

  1. Insure that output of each channel is as follow: (Using Mission planner to do so)
    Values are in microseconds.
    Min = 1000 Middle 1500 and Maximum 2000. (uS micro Seconds).

  2. If your transmitter is a good one then setup all the channel in use as above.

  3. Calibrate your transmitter using Mission Planner. (This will avoid later problems)

  4. Using a servo tester where the output values are shown, insure that:

    • Minimum value is 1000, Middle 1500 and Maximum value is 2000. (uS micro Seconds).
  5. Calibrate each ESC throttle with your servo tester according to the ESC notice.

    • Many ESC (Not all of them!) accept the following sequence:
    • Max (2000 uS) on servo tester.
    • Apply power to the ESC (Some ESC beep to tell you they did understand max value).
    • Min (1000 uS) on servo tester. (Some ESC beep again to tell you they did register min value).
    • Power off the ESC.

You’re done.

Hope this help.


on the settings I have saw this: the minimum value is 1100 and the maximum is 1900.
after I’ve boot the fc… push the safety switch i have the advertising that the copter is armed but the esc have a continuous beeping.
When i give few throttle the motors dont spin… only beeping from the escs.
I’ve a taranis x9d plus with x8r receiver.

I gave you a way to make it working in details.

For simplicity better to have 1000 1500and 2000. Values to be set in:

  1. your Transmitter

  2. Mission Planner

  3. in the servo tester.

The fact that the ESC are beeping means that they are NOT receiving anything from the FC

Which colour is your FC showing?

My feeling is that something is not happening.

An example would be that GPS lock is ticked in the “prearm parameters” and that you are inside your house without lock.

Even if you succeed to arm, you still better have your ESC calibrated or very unpleasant problems will rise…



I’ve done a double check… in the hud of MP i don’t have any info… im sure the esc are not fully compatible with ardupilot 3.6.6