Servers by jDrones

Errors uploading missions

ardupilot
mission-planner
pixhawk
(Kenny Trussell) #1

I am having trouble uploading missions to Ardurover from Mission Planner. I have had this trouble for a few weeks but for relatively short missions, I could retry enough to eventually get the waypoints in. Tonight I decided to troubleshoot and am unable to determine my problem. I have tried 2 different sets of telemtry radios (different brands) and have the same results.

Using USB to connect to the Pixhawk 1, I can usually upload reliably.

What I am getting with the telemetry are messages like the following:

mission%20upload%20error%204

Sometimes I get this:

mission%20upload%20error%205
If I click details I get this:

The messages like this may happen early in the upload attempt or at any place during it. If the number of waypoints is small, I can eventually retry enough to get them in. My missions can be several hundred when mowing a large area.

Attached is a dataflash log and logs from Mission Planner are located here:

Thank you for any help!

Long range UAV link 100mw for 60KM was designed and tested
(Shawn) #2

Hi Kenny, do you have a pic of the radio settings?

(Kenny Trussell) #3

Shawn,
Thanks for helping. The radio I have used for a year with no trouble is a 3DR 433 MHz 500mW clone. Here is the radio settings screen:

The other radio is a Skydroid M12L combo RC transmitter/receiver with telemetry also. I can try to find the radio settings for it also, but the problem occurs on both units. I figured the 3DR one is the most familiar to troubleshoot with.

Thanks,
Kenny

(Kenny Trussell) #4

A bit of an update. In experimenting more with the 3DR, the transfer is much more reliable than the Skydroid. It works successfully about 3 out of 4 times. The Skydroid never gets past 200 or so waypoints before failing. I am uploading a mission of 419 waypoints.

I cannot see a way to get to settings on the Skydroid. I will ask on the post related to the Skydroid M12L system to see if others are having the issue.

An example of a large waypoint file that always fails with the Skydroid: Shop Back Yard N,W,Sfixmow.zip (4.6 KB)

If you have any insights, though, please help! Thanks so much.

Long range UAV link 100mw for 60KM was designed and tested
(Andrea Belloni) #5

Hi @ktrussell
you are using your 3DR radio at 12.5mW, from the wiki:

Tx Power (default 20) : the transmission power where 1=1.3milliWats, 2=1.5mW, 5=3.2mW, 8=6.3mW,11=12.5mW, 14=25mW, 17=50mW, 20=100mW. This should be set to conform with your local regulations.

(Kenny Trussell) #6

Thanks for noticing that. I honestly have never touched those parameters and had good success last year when I was using that radio, except that the range was not as good as I would have liked. I can see why, now.

1 Like
(Andras Schaffer) #7

With 3DR switch off ECC, and increase power output to 100mW.
Then check comm statistics while uploading waypoints, (click stat on the upper right corner of mission planner) Link quality must be above 98%
image

2 Likes
(Kenny Trussell) #8

Thank you guys. With those changes, I have excellent results at the moment with the 3DR telemetry radios. I can’t say the same for the Skydroid. Bad packets lost is steadily climbing with the device just connected passing normal telemetry, not even trying to upload waypoints (short video clip attached).

I don’t know how to edit parameters for it. I will see if I can get support from the vendor, but open to any thoughts ???

The Skydroid version of the tower app for Android WAS able to upload the same file successfully. It was painfully slow, so I suspect it may have had a lot of retries going on, but there is no progress indicator or anything, so I couldn’t really tell.

20190811162122.zip (865.7 KB)

Long range UAV link 100mw for 60KM was designed and tested
(Shawn) #9

I was going to say turn off ECC too
And also check BRD_SERx_RTSCTS is set to 0 (disable)

(Kenny Trussell) #10

Thanks. It was on AUTO which was working, but I just changed it to disable (0). I also tried all 3 combinations on the Skydroid serial channel but no improvement.

(cala2) #11

M12L by usb to Mission planner

(Kenny Trussell) #12

Thanks, @cala2. I just connected my remote control via USB and have NO lost packets and uploaded beautifully, just as you reported. I then reconnected via Bluetooth and have the lost packets and upload issue. Are you able to use Bluetooth to try?

(cala2) #13

Only with android, I don´t have BT in my pc.

(caoxueyu) #14

If missionplanner or QGC gets the confirmation information of flight control and then sends the next waypoint, the problem will be solved. Because the bandwidth of the radio is much lower than that of Bluetooth and USB.

(caoxueyu) #15

The Bluetooth function of Win10 has very high packet loss. It is recommended to use special Bluetooth virtual serial port software. Forgive me for forgetting the name of which software

(Kenny Trussell) #16

Thank you for your reply. I will look for that and see how it works and report back.