Servers by jDrones

Errors - Disarmed, Failsafe, NO RC Receiver and motors do not stop after operation or not disarming

Hello,

Working on a Quadcopter with APM Copter/ PX4. All the calibrations done successfully.

I can understand that the NO RC RECEIVER error may be shown as the throttle is below failsafe. Once I increase the throttle below failsafe, the FAILSAFE error goes away. The moment I go beyond failsafe level the LED turns SOLID GREEN on the Board, removing the error NO RC RECEIVER and DISARMED. But the below shown trials are proving quite irritating.

Trials

  1. When connected with USB - Transmitter ON. Receiver powered ON (separately). Pushed the RED arming button. RED LED turns solid but the HUD shows DISARMED. The board kept flashing yellow LED. After a few trials, got a solid green LED on the board. Motors started rotating.Tried with increasing and decreasing Throttle, everything is fine. Lowered down the Throttle to stop motors. After lowering the Throttle, the board started flashing yellow and motors kept rotating. Disconnected battery to stop the motor operation.

  2. When connected with 3DR Telemetry - Transmitter ON. Receiver ON. Pushed the RED arming button. RED LED turns solid but the HUD shows DISARMED. The board kept flashing yellow LED. After increasing the Throttle stick above failsafe value, board got a flashing green LED. After few up and downs in throttle stick, LED turned Green solid. Right YAW and Motors started rotating. After a point, the speed of the motor not varying or not increasing. Decreased down the throttle to stop the operation. the board started flashing yellow and motors kept rotating. Tried to disarm through Safety switch, but no success. Left YAW too did not disarm the motors. Disconnected the battery.

Now I am looking for the solution to this issue ASAP. Can anyone please help me out with this?

Thank you for your help

First, set your throttle failsafe properly.

My throttle failsafe is at 980. The lowest position value of the throttle stick is 964 (trim at the lowest position). Transmitter’s Failsafe is at 20%.

What’s the other thing that I have to set for throttle failsafe?

Set the “FS Pwm” value to be:

at least 10 PWM higher than your Channel 3’s PWM value when the throttle stick is fully down and the transmitter is off
at least 10 lower than your channel 3’s PWM value when the throttle stick is fully down and the transmitter is on
above 910 (copied from)

http://ardupilot.org/copter/docs/radio-failsafe.html

1 Like

Okay. So I have to follow both the steps with transmitter ON and OFF? OR the either one will work?

Yes.
This might give you an idea.

Thank you for the link and help.

I still have not got my issue resolved, though.

I am sharing some images that shows my MP screen and PWM values of Throttle.

  1. Radio ON, Radio Failsafe is at 20% (by default), Stick at lowest position, Trim at lowest position.

  1. Radio ON, Radio Failsafe is at 20% (by default), Stick at lowest position, Trim applied. The green value has shown up now.

  1. Radio OFF, Radio Failsafe TURNED OFF, Stick at the lowest position, Trim at the lowest position. The PWM value has increased beyond 1100 (which is higher than the failsafe setting limit - 925 to 1100)

4.Radio ON & OFF (tried both), Radio Failsafe is turned OFF - NOR, Stick at lowest position, Trim at lowest position. There is no change in the throttle PWM value.

Do you get anything from this and help in resolving the issue?

Still I get the same errors - Disarmed, No RC receiver, Prearm check - Throttle FS Value

Also, when I try to connect through terminal and test each motors, it does not work. I get a hell lot long program that keep on coming that never stops. So, I am not able to test motors too. It can be an inter-related issue, I think.

Hi,
I don’t know which Tx you are using and I won’t be much help there, sorry.
Refer the Tx manual to set the failsafe.
Remove all trims & do a fresh radio calibration…Let 980 be the failsafe value. What we want is, with the throttle stick fully down, the channel 3 value must be 1000 when Tx is ON & 960 when the Tx is switched OFF.

I am using Futaba T10J.

I can just Enable/disable the Failsafe, it percentage is fixed at 20. Though, I have not checked the manual, yet.

Without trims and with new settings too, the PWM value remains as it is.

Even if I keep 980 value manually, the throttle PWM values with transmitter ON and OFF are far different as said before.

Hi Harish, watch this video. Even though old , it will help ,sure.

I tried this method too. But the errors are still the same.

All you are showing in the pictures is exactly as it should be. The only problem is the TX/RX throttle failsafe at 20%.
As soon as you turn off your TX, the receiver puts out a 1154us PWM signal.
You have to set it lower for Arducopter to recognize a signal loss.
And a word of advice:
Never use the throttle trim with electric motors, it can lead to bloody results. Leave the throttle trim centered and do not touch it. If you need to adjust the throttle range (which should not be necessary after ESC calibration), do it with subtrims. Playing with the throttle trim is most likely what causes the motors not to stop and the copter not disarming.

Ok. I can understand what you have said. Your advice is correct. I never apply trim when I am using electric motor for plane and copters. I have applied trims for trial purpose only to show the other guy what happens when I give trim and how PWM value changes in my Transmitter. I do not use trims so there is no issue with that.

So, how to setup this 1154 to the lower value than my failsafe value?

Try setting failsafe to be -20% , just guessing…

I have already tried to change that value but I think I cannot vary that 20% value. I find it to be a preset one.

I recommend reading the T10J manual again. A preset failsafe value pretty much negates the purpose of a failsafe. Each type of vehicle needs different values for failsafe. A radio for 300 bucks should not lack such an essential feature.

There should be a way of changing that 20% value to something else, like -20%

Don’t know if your Tx is similar to my 8fg, but maybe this would help:

en F/S mode was selected)
â–  F/S position
② In the mode selected state, set the F/
S position by holding the stick of that
channel in the position you want to set
and press the Jog key for 1 second.
â—Ź A confirmation beeping sounds to
show that the servo position was


set.

Servers by jDrones