Error velocity variance ekf

In the last week, the gps that I have been using for 1 year started to giving error. When I move the plane, ekf ​​velocity is broken and the location of the gps is broken. I replaced all the cables connected to the gps. I tried 3 different gps and they all had the same problem. I tried all the gps on different planes and it didn’t show up. I tried the parameters of the working plane on the other plane and it gave the same error again. When the plane is at a stop, the GPS is correct, but its position deviates in sudden movements and returns to the correct position after 5 seconds.
Does anyone have an idea?
Please give an advice. I’m waiting for your answer. Thanks in advance

That is interference. What else changed in the plane? Did you add a transmitter?

If you get vel variance by moving the params from one aircraft to another, it suggests that you may have changed (intentionally or accidentally) one of the EKF params (E.g. EK2_VEL_I_GATE). Try wiping the eeprom and reseting all parameters back to default (flash to another vehicle firmware E. G. Copter that will wipe the parameters, then flash back to Plane so that you have all default params for plane) then use the param compare feature in mission planner to carefully bring across parameters from your previously saved param set. Do not copy across any params starting with EK2_, EK3_, or GPS_ unless you understand exactly what they do. (Note: You are likely going to need to redo all accel calibrations in this process too). Try that and see how you get on.

As it got better after accelerometer calibration it then broke down again. When I tried with a different pixhawk, the problem was not resolved. When I compared the parameters, I couldn’t find any changes other than the IMUs used. I have the same problem with the default parameters.

We covered the motor cable with aluminum foil to avoid the Faraday cage effect. I don’t remember if it started after this incident.

Can you post a log that shows the pos variance. Might be able to help more then. Maybe some pics of your vehicle and setup too.

When we started the camera image transferred from raspberry, we realized that it did this but with this configuration it did not give an error before. After trying 5-6 times, we are sure that this is the source. Definitely, when we start taking images from the camera, the gps data is corrupted.

I glued the gps directly to the carbon fiber body. Should there be a space under it? Could it be having such an effect because of the carbon fiber?

You need to distance the GPS antenna from the camera cable.