Servers by jDrones

Error uploading firmware

I have been trying to upload new firmware to a pixhawk 2.1 cube for the past two days using MP 1.3.62 build 6847 and am constantly getting ERROR:No response from board. Oddly enough it detects the board initially as px4v3, once it reads the hex file and the usb make a noise like it is getting disconnected then it switches over to scanning components but MP also gives me an audible read out “mode switching to hold” like MP is connecting to the board. The it will always fail I have tried loading custom from rover 3.5.0 to plane dev 3.10. nothing has worked at all.

Give QGC a try. It has worked for on occasion with problematic flash with MP.

I just tried force bootloader and that has worked for now but this has never been an issue with MP that i have notice before nor when flashing firmware has it ever played a sound like its connected to MP. Not sure how to mark this as solved but I have switched back and forth from 3 diff firmware version and had to use force bootloader all times.

can you send me a copy of missionplanner.log
c:\programdata\missionplanner\

just want to see what is causing your issues

Servers by jDrones