Elevator doesn't work after launch

Everything works fine on the ground. But few seconds after the launch, elevator doesn’t work and plane crushes. We tried it twice with different pilots but got the same result. We tested the receiver and transmitter from a far distance, we tested the servos on full throttle while same propeller is on the plane. Everything seems fine on the ground. I couldn’t find anything weird on logs. We feed the pixhawk 2.4.8 with 50 amp esc’s 5amp bec. We will use a 60 ampere esc and a power module next time but I can’t make sure that the problem is with the current or not and we don’t want to launch again before figuring out what’s wrong. Here is the flight log and video. Any thoughts?

Check if you inverted the inputs… RC pilot seems to command down elevator… and the servo os getting commands as well… so I would say you have an configuration error.

1 Like

Yes elevator was reversed. We were using px4 before and just changed to ardupilot. I think elevator is defaultly reversed in ardupilot. We will launch again today. Thank you for your reply.

some RC equipment produce short pulses when the pitch stick is in “nose down” (forward) position.
“Normal” is that pitch forward (stick forward) produces longer pulses (higher pwm numbers)

hence: a normal RC pull up input should show low us values.

…this may be reversed in the RC radio,- depending on model and configuration.