Servers by jDrones

EKF2 breaks sound barrier and EKF3 refuses to arm

Hi all,

PH2.1 with Here GPS refuses to work with latest stable plane (tested both EK2 and EK3). Questions first, details follow.

  1. Has someone been able to run stable plane on PH2.1 with Here GPS?
  2. Has someone been able to run master copter on PH2.1 with Here GPS?
  3. Are you using EK2 or EK3 ?
  4. What parameters and/or wiring changes have you made in your build to avoid that your vehicle thinking that it breaks the sound barrier ?
  5. What are your EK3_MAG_I_GATE, EK3_MAG_M_NSE, EK3_GYRO_P_NSE, EK3_ACC_P_NSE, EK3_GBIAS_P_NSE and EK3_ABIAS_P_NSE values ?

I have an Pixhawk 2.1 that I flashed with first copter, and then with Plane 3.8.4 (latest stable).
This causes all parameters to reset to their defaults.
Then I did a accelerometer calibration and a compass calibration using mission planner.
Rebooted and waited two minutes… the ground speed seen on mission planner increases up to 520m/s (that is beyond the sound barrier). The position remains stable at all times, but the attitude starts to go crazy at some point.
This is stock stable release with default parameters siting on the ground, doing nothing !!!

Then I disabled EK2 and enabled EK3, again, not changing any other parameters.
This time the ground speed remains at zero and the attitude seams stable.
But the pre ARM checks do not pass I get “AHRS not stable”. So there is something funky with the EKF attitude as well.

Then I retested with copter master (using the copter defaults and after accel and compass re-calibration)
EK2 breaks the sound barrier again, EF3 gives “preARMcheck: gyros still settling”

I had similar issues with a second PH2.1 board some months ago.
I have a second copter, with a similar build. And that one is running fine with PH1.

DF log from master Copter and EKF2: http://www.transfernow.net/199ma95451go

Because IMU2 is noisier I disabled it, and switched to EKF3:

I fly master with default param both with nuttx and chibios version on copter and it was working well. And without gps as it was indoor

I did some more tests on this.

  1. Flashed PX4 FW … to make sure the parameter values get wiped.
  2. Flashed Copter 3.5.5 and calibrated.
  3. It worked… EKF2 did not diverge.
  4. Flashed Copter from master from 2017-08-29, no recalibration
  5. It worked … EKF2 did not diverge.
  6. Flashed Copter master from today, no recalibration.
  7. It diverges, and breaks the sound barrier again :frowning:

@Piere can you post you parameters ?

As a side note, it’s not necessary to load another firmware to wipe the parameters. A faster method is documented on the wiki here.

It might be good to check the compass orientation is zero and not “27” or “29”. It’s unlikely to be related but we did have incorrect compass orientation for the new Here GPS/compass modules back in August. It’s fixed in master though now.

Can you check if it diverge without gps ?

@rmackay9 the code from August has the Here GPS/compass bug, but works.
The code from master does not have that Here GPS/compass bug, but it does not work.

Servers by jDrones