Servers by jDrones

EKF Failsafe - Log Analysis

Hi All,

I have had a crash with one of my quadcopters, uses the cube with the Kore carrier board and here2 GPS and herelink.

I was performing a hover test to test some new batteries and the quad headed off on its own, and did not seem to react to any RC input.

I am new to analysing the logs, but it appears to be an issue with the EKF? potentially loss of satellites?

Would appreciate it if someone could kindly give me some assistance in analysing what the problem was?

log file attached.

Sorry log didnt attach, download link here https://www.dropbox.com/s/hkgm00orjeqjynm/2019-11-20%2018-09-21.bin?dl=0

Many thanks, Charlie.

Looking at your logs it looks like your GPS had a reboot in flight. There is a known issue where this happens occasionally with ublox GPS’s that I believe is getting patched in copter 4.0. If your copter was in Pos Hold I could see this being a reason it drifted off as it also appears that the copter has not been tuned. It wouldn’t hurt to check the connections going to the GPS to make sure they are secure. I’ve had the same GPS reboot issue happen to me three times on three different aircraft and I’ve never had a crash it would just go into the Land flight mode, so there could be something else at play here.

Many thanks for your reply. Yes tuning had not been done yet as the flight was to be just a hover test to ensure that everything worked well with the new LiHV battery. GPS connections are fine.

Hey @NZ2019,

Did you get the exact reason for the GPS reboot?
I have faced the same issue thrice.

Things I have tried:
a. Changed the GPS module
b. Changed Pixhawk

One of the flight logs:
https://drive.google.com/file/d/1A96bNNLvo5B6Qx7fT3pvnODYLdjrolO9/view?usp=sharing

Still the problem persists and I have not been able to find the exact solution for it

Servers by jDrones