EdgeTX Telemetry Altitude and Compass Sensors incorrect readings

I am running EdgeTX v2.8.1 edgetx-tx16s and getting telemetry data from an ELRS Rx Radiomaster RP3 2400RX (both running ELRS v3.2.1).
Hardware: Matek H743-Slim V3, Matek AP_PERIPH GNSS M10-L4-3100.

The Alt displayed on the TX16S Telemetry starts with 0m until the GPS M10 gets a lock and then the Alt readings on the TX16S are completely incorrect even from the GPS ASL. Most of the times a positive value (e.g. 16, 18, 5 etc.) when the MP displays ~0 m. The Arducopter (v4.3.6) show correct altitude for HOME 0 m alt. on the Mission Planner (1.3.80) Telemetry (see images below).

The GPS displayed on the TX16S matches the MP reading. Also noticed that the compass readings do not match. The MP reading it “points” to the correct direction.

Before GPS lock no ASL value.

After GPS lock with ASL value.

TX16S my Telemetry Widget:

TX16S Model Telemetry discovered sensors:

MP screen:

I searched for days for any information of EdgeTX telemetry and how to relay the Sensor number and ID and what will be the equivalent Ardupilot parameter but have not found anything.

I have put posts in the EdgeTX, Ardupilot and even ELRS Discord but I have got no responses.

Any thoughts, ideas, URLS to further investigate this issue will be most appreciated.

Even the headings look different (unless you moved the copter between screenshots)

Yes, you are correct. TX16S 26.56 deg. and MP ~160 and during that time I checked where the physical “nose” of the quad was pointing. MP is correct.

Just to eliminate the possibility that pictures are taken at different times. I just re-checked and all the numbers are the same TX16S heading jumping from 17 to 32 and even negative deg. The MP show a solid 103 deg. I also pulled my VION compass and I got a reading of 103~105.

The following image is the sensor configuration on the TX16S (EdgeTX).

If the data was consistent then I could come up with an offset or/and ratio to calibrate the value but the numbers jump all over the place!!!

So the mavlink telemetry to mp is all working and showing correctly measured sensor values but the transmitter telemetry is mismatched with source value addressing or inconsistent due to not having a working telemetry connection through the rx

Heading obviously should never go negative, maybe it’s not looking at the correct data, are you using the yaapu telemetry script?

That’s correct about the MP data. I tend to believe the “auto discovery” process of EdgeTX through the ELRS Rx is not working very well and there is not much documentation about how these “sensors” (telemetry variables) are assigned IDs on the EdgeTX. The MP is getting the correct data either through the FC USB or the SiK Tx/Rx.

Hopefully someone from EdgeTX and/or ELRS wil engage with this issue. I am out of troubleshooting steps and I only rely on the MP for flying data. At least the battery and RQ quality values are correct and at this time more important than having navigation information on the transmitter.

Id be interested to know how you have your rx connected and what serial/crsf parameters you have set, i tried to connect the same rp3 reciever to a h743 board and had no success getting rc channels to read into missionplanner.
As soon as i get mine working i will be able to compare edge tx telemetry data and see if i have the same problem, im on same fw elrs and same edge tx version

For the Matek H743-Slim V3 FC:
I am using the Rx6 pins on the FC

ExpressLRS Receiver



Thanks, i think i tried exactly that at one point, the alternate board config allows serial 7 to work as a uart rather than a soft.
Prot 23 is for crsf
Rssi3 is for telemetry source
So you are connected to tx6 and rx6?


The red box shows the pins I solder the Rx. Just remember to cross Tx from Receiver to Rx of the FC etc. Same pads worked originaly for me using a DSMII satelite receiver; no Tx for telemetry of course.

Are you using yaapu telemetry script?

No I do not use yaapu lua. I tried and it keep crashing lol

If the data is wrong in the simple interface I don’t think the yaapu lua will fix it.

Do you have a Radiomaster Tx too?

Yes, im using a zorro and nano ranger module.

The rx has solid light when tx is on so i believe it is bound correctly using phrase. But i get no rc channel data in missionplanner. I tried using another uart pair but it didn’t work for me either. I wasnt able to enable crsf in the yaapu config utility as it wasnt part of the install on the taranis version of the yaapu scrtipt but i thought it should only affect the telemetry anyway and not the rc signal

I have yaapu telemetry working perfectly with frsky xsr reciever and inbuilt 4in1 transmission but it doesn’t provide good range at all for boat 200m only, so i bought elrs to range test but ive not got it working yet

Can you access the ELRS Tx and Rx from your WiFi using the ELRS Configurator?

Does both units have the same ELRS versions and same settings?

I had some ELRS early issues and get fixed with matching versions and having same parameters on both ends.

I will make sure i have same fw on tx and rx. It seems starange, every elrs vid on the net is about how to flash elrs but in thinking it comes preloaded with 3.x why am i even flashing anything cant i just set the binding phrase and a few parameters and use it?

It’s really great having so rapid development and latest and greats features and bugs squashed but also “we the users” are doing most of the QA; I think. :smiley:

The 1st TS16S MKII I got hang after flashed with EdgeTX v2.8.1. Even re-writing the EEPROM with zeros, erasing it and re-flashing it will not bring it back. After some chat, I found out that some units will do that if you tried to update the firmware… They send me another one and there was no problem flashing it with the same binary.