Eclipse: Build Finished. 0 errors, 0 warnings but no build file


I am new in the ardupilot community (67Years, since 15 years develloping and flying all kind of copters). As I am interested in software development, I downloaded from the github ArduCopter files and installed cygwin64. The Eclipse IDE is allready on my computer. The build worked fine so far. Build Finished. 0 errors, 0 warnings but I can not find the build file. (hex, elf or what ever)
In the build log I can see: the message “could not configure a C++ compiler!”
What could be wrong in my setup?

Some time later: something sceems to be completly wrong with my eclipse setup in combination with cygwin64
So I will drop that path and continue with WSL This step is done. Now I have installed Umbuntu and I have copied the githup ArduPilot files to my local directory.
Not sure, what dto do next. How can I connect Eclipse to Umbuntu ?

Obvious I dont need Eclipse when I am in Umbuntu.
The gcc-arm cross-compiler is here: ArduPilot firmware : /Tools/STM32-tools
So I need that file:
I copied it with wget to the directory TARGET_DIR. That worked
Now I hope that I can use TAR to extract it.

While I understand you’re most comfortable in the Eclipse environment, the easiest path to success is using WSL2. If that’s all you intend to use WSL2 for, you don’t even really need to worry about the docker container instructions. Just follow the basic setup for WSL2 and build using the command line.

For editing, it’s pretty painless to set up VS Code (which is just a fancy text editor with some bells and whistles that you can either embrace or ignore). I’m sure you could use Eclipse for simple editing and then build using CLI, but I’m afraid I have almost zero experience with Eclipse, so I’m not much help there.

Thank you for your reply
I am on the way to install WSL2
Lets see how that works

Now - some times later - it works
Ubuntu-22.04 is up and running at WSL2
Visual Studio is up and running now.
Thread closed