DYS XSD 30A V2 BLheli-s esc PWM issue with Pixhawk

After passing all the basic setup’s in MP I tried to run up the motors but they only get to about 15%.
I had a look at the pwm signal out of the PX4 with an oscilloscope and can see the motors start at about 50% duty cycle then as I increase the throttle the speed increases slightly and they stay at that speed even though the throttle is at max and the duty cycle is at about 90%.
So I have throttle range but the esc’c don’t respond. I have flashed esc’s to the latest firmware.
Also I can’t get passthrough to work as well, maybe related to the esc’s?
I must be missing something somewhere.
Has anyone had this type of problem.

I’m not much of a BLHeli expert but I suspect it’s some sort of configuration issue with BLHeli ESCs (i.e. not AP related). So for example, I found recently with some BlueRobitics thrusters that if I used a DShot BLHeli ESC, I needed to set the “Low RPM Power Protect” to “Off” (in BLHeli, nothing related to AP).

P.S. I’ve corrected the title of this thread to clarify the difference between hardware and software.

  • ArduPilot is software
  • Pixhawk is hardware
  • the other 3 letter acronym is for a different flight stack (i.e. software).

Thanks for your help setting the “Low RPM Power Protect” to “Off” solved the problem.