Servers by jDrones

Dual-motor tailsitters


(letpi) #1402

Nice flight and the power needed is now much better than previously, around 100W for 50Km/h is fine for such a big wing.
Maybe before tuning the TECS, check vibration level and also the barometer. Altitude and throttle variation are characteristics of high vibration for a multicopter in altitude mode because accelerometers dont like vibrations. I am wondering if it could be the same for a plane. For the baro, I am thinking of pressure variation inside the fuselage. I never tried FBWB, do you have same throttle variation with other altitude controlled modes like Auto and Loiter ?


(lorbass) #1403

Thank you for the Feedback.
Here the log of Test 12:
https://drive.google.com/open?id=1esfMqC8X6URKhvdxXIQeDiav7fHb-bxa

I feel the Vibs are good, much better than in my copters.
In Loiter the throttle variations are low.

But in Test 9 with this Log:
https://drive.google.com/file/d/1un00jXyUZvxgBU3r5QUQKewTzElPgbRy/view?usp=sharing
No ThrOut Oscillations in FBWB?

The difference is, that now the ARSPD_USE ist enabled.

Perhaps you finde more in the Log.
Regards, Otto


(Rolf) #1404

Hi Otto,
Congratulations. Great Plane !

ThrOut Oscillations in FBWB (and perhaps in other modes with automatic throttle like CRUISE, RTL):

First of all, you should calibrate the airspeed sensor better. Looking at Groundspeed and airspeed while loiter:


Average airspeed while loiter-mode shows 12,5 m/s. If you look at the amplitude of the groundspeed during the circular flight, airspeed is only 11 m/s. So you should reduce the parameter ARSPD_RATIO from 2.7 to 2.1.
The calculation base you will find there:
http://ardupilot.org/plane/docs/calibrating-an-airspeed-sensor.html?highlight=airspeed#manual-calibration

Throttle-oscillations:


At minute 5 you fly in stable level flight with about 35% throttle, the indicated airspeed is about 12.5 m/s. Due to the too high value of ARSPD_RATIO, the measured airspeed is a little bit too high, so let’s assume 11,5 m / s:

The aircraft needs 35% throttle to fly in a stable height at 12 m / s.

So reduce TRIM_THROTTLE from 45 to 35 and change TRIM_ARSPD_CM from 1200 to 1150.

Lastly, you should set ARSPD_FBW_MAX/MIN to realistic values and the oscillations in FBWB will probably be significantly lower or disappeared.

Later i still tune in TECS_CLMB_MAX, TECS_SINK_MAX, TECS_SINK_MIN and the plane flies perfectly in autothrottle modes as well.

Rolf


(lorbass) #1405

Hello Rolf,
Thanks for the feedback, thats a real Tutorial, will study it carefully.
Have you seen, in Loiter it was nearly good?

Airspeed calibration: I icreased this value, because in the last flights it was just oposite (Ground/Airspeed)
But aniway, will follow your advices.
Regards, Otto


(Rolf) #1406

You certainly know that you should have covered the pitot tube while booting (As long as ARSPD_SKIP_CAL is 0).
Regards, Rolf


(lorbass) #1407

I covered the pitot tube. And then made preflight calibration with MP/Actions bevor arming as read in the Wiki. Or is there an easier method than a note book in the field?
But nevertheless, the indicated Airspeed then is always about 2 kmp.
The same in above video.
Otto


(Rolf) #1408

2 kmph with covered pitotrohr are no problem. In flight this corresponds to much smaller values.

  1. If the offset variance between flights for your sensor is low enough you can enable ARSPD_SKIP_CAL

or

  1. you use an SDP33 sensor

Rolf


(lorbass) #1409

I 'v study your advices carefully.
Your graphs where inctructive. So I detected a possible reason for Throttle oscillating.
The Param TRIM_ARSPD_CM is at 1200 (12 m/s), and the ARSPD_MIN also at 12 m/s. (Default 9)
I set this param higher to avoid a stall, because I have no experience about the stall speed of this
Wing with 2800 gr. But I did not found a note in the Wiki that TRIM_ARSPD_CM should be higher than ARSPD_MIN

  1. What about this hypothesis?
  2. Still satisfied whit SPD33 ?
    Regards, Otto

(Rolf) #1410

One of the devs should be able to say something valid. At VTOLs, ARSPD_MIN is the transiton speed. In FBWB mode you control airspeed by throttlestick in the range from ARSPD_MIN (Throttle 0%) to MAX (throttle 100%). In my oppinion it would make no sense if TRIM_ARSPD_CM would be outside this range.

Fully satisfied with the SDP33. I installed the SDP33 sensors in the tiltrotor and in the quadplane.


(lorbass) #1411

Is there another supplier than Drotek?
Made verry bad experience with a GPS from Drotek.
Compass didn’t work, found that the soldering points inside where manipulated by a amateur.
Had to send it back, was replaced, had to pay a second time the custom fees (28€) due to mal declaration.In total finally 140€. 4 times the price of a similar from BG.

In the meantime found a Value in MP (TECS.th) that shows exacly the same oscillation (Loiter versus FBWB) as the Value CTUN.ThrOut.


But no idea where it comes from.
Regards, Otto


(lorbass) #1412

Issue Throttle oscilation solved.
I set ARSPD_MIN to 10, this is 2 m/s lower than TRIM_ARSPD_CM which is 1200 cm/s.
And the nice Bumbelbee Sound is back :slight_smile:


(lorbass) #1413

Another Test flight to optimize FBWB, ARSPD_RATIO and landing with more than 20 kmph gusty wind.


@iampete
Thanks to for the param q_tailsit_thscmx, now this angle is possible without pumping.
What can happen if the Q_ANGLE_MAX ist increased more than 5500?
Would it change to FBW?
Only this ugly start phase remains.

(lorbass) #1414

With the small Wing I’v not seen this shaking start during 47 Flight Tests.
Here the vid of Test 47.


And the Log of Caipirinha
https://drive.google.com/open?id=0Bxldq38bfbqHY1oyakZaVENnd1k

And later in Test 50 with FW V 3.9.1 also no shaking.

May be to reduce Q_A_RAT_RLL_D OR P?
Because I can see havy oscillations in PIQR of P and D at this start phase in e.g. this Log.
https://drive.google.com/file/d/1un00jXyUZvxgBU3r5QUQKewTzElPgbRy/view?usp=sharing
Regards, Otto


(Peter Hall) #1415

You can go as high as you like, I have used 10,000, although over 8000 is not recommended. You just have to be careful not to gain too much airspeed or you will get oscillations.

It only happens if you have high roll gains, particularly D.

As you say this would fix it but I think your better off with higher gains and shaking at takeoff.


(lorbass) #1416

Thanks for so quick investigating my issues.
Will try carefully with 6000.
Q_A_RAT_RLL_D gain is 0.006. (Caipirinha 0.02)
Yes, the behavior in Roll is now OK, will try a little bit lower of D.
But you are right, better ugly on the bottom than in the air.:slight_smile:
Regards, Otto


(lorbass) #1417

Q_ANGLE_MAX = 6000 works great as to see in the video.
Q_A_RAT_RLL_D from 0.006 reduced to 0.004 didn’t help for a better Takeoff.


(rollys) #1418

Impressive! Making it even more is the Dashware (I presume) gauges. Would you mind sharing those gauges or provide a link where you may have downloaded them? Thanks.


(lorbass) #1419

I assume you know Dashware and theire standard gauges.
Others are “handmade” or developed by @palm369
Which ones do you mean?


(lorbass) #1420

I ordered these by Amazon. Returned by UPS because Package damaged. Not replaced by Amazon. NO refund within 5 weeks. When something is not correct: “Contact us” but not mentionned where.
A negative post in the shop was rejected. So be carefully.


(rollys) #1421

The airspeed and compass on the bottom right and the Roll/Attitude, just to the right of the flight mode.

Thanks.