DShot600 ESC/Motor Setup help please?

ESC/Motor Setup not working. I would greatly appreciate any assistance please. Info on current setup and specifics on issue are as follows.

Attempting initial setup of Arducopter with
ver 4.1.0 on Matek H743 Mini flight controller (H743 firmware)
ORI32 4-in-1 ESC (BLHeli32)
Using Mission Planner 1.3.74

Radio Cal complete & successful
Accelerometer Cal complete and successful
Compass Cal complete and successful
Moes Setup complete and successful

Mission Planner Motor Test does nothing (a couple beeps but motors don’t spin). Tried increasing % from 5 to 10 to 15. Nothing changed. Attempted test with LiPo battery as power (not connected to computer with USB). Get first 3 ESC tones but not the last two (the last two indicating if throttle signal is detected). Have tried different JST wiring harness from flight controller to ESC. Same thing happens.

I’ve got an Arm/Disarm switch setup as an Auxiliary function on channel 5 (due to ExpressLRS protocol requiring Ch 5 for Arm/Disarm). I have therefore assigned Modes to channel 6.

Attempted to connect to BLHeli32 configurator (which I normally use for my Betaflight firmware quadcopters and am somewhat familiar with). Com Port 14 comes up as Ardupilot MAVLink
Com 15 comes up as ArduPilot SLCAN
Have tried both of these. Is the comport supposed to be showing a different driver for the com port?
Com 14 returns the following results in image

ESC/Motor Parameters set:
SERVO_BLH_AUTO = 1 (for automatic motor mapping)
MOT_PWM_TYPE = 6 (for DShot 600)
SERVO_DSHOT_ESC = 1 (to allow DShot commands)
SERVO_BLH_TRATE = 10 (default)

Setup looks ok. What happens if you leave SERVO_DSHOT_RATE at 0? This may be down to the ESC

First of all Andy, I’d like to thank you very much for your response. I am “dead in the water” until I get this resolved and am at wits end here.
I have changed to
SERVO_DSHOT_RATE = 0 per your request
Results are the same.in both Mission Planner motor test and also BLHeli32.
Still won’t connect to BLHeli32 and still get same error message.

What do you mean “down to the ESC?” please

Passthrough is very, very timing sensitive so much so that individual ESC/FC combinations may or may not work.

I’m using an Ori32 4in1 with a Kakute F7 Mini and it’s working well. Let’s see your parameter file perhaps there is something else to see.


Its possible that the installed version of BLHeli might be too old for passthrough to work?

Unfortunately, its the latest version of BLHeli32, so I don’t think that’s the issue

Thanks Dave.
I think you’re asking for the saved Full Parameter list file?
If so, here it is:
Freedom Flyer Parameter File 25Oct21.param (20.5 KB)

SERVO_BLH_DEBUG affects the timing - try setting it to 0

Thanks Dave,
Link to Full Parameter List file is here

It was originally at 0.
Changed it to 1 to see if that would work and it did not.
So, now I changed it back to 0.
Same result.

Other than use of a safety switch I don’t see anything that sticks out. I would imagine you tested it but same result if it’s disabled?

Thankyou for taking a look Dave. I appreciate it.
I believe you’re speaking of what I call the Arming Switch (Arm/Disarm) on Channel 5.

I have not disabled it to give it a try (yet).

I’ll give it a shot tomorrow. I’m also going to look at disabling pre-arm checks (if any) as a trouble-shooting mechanism. Not clear how they might be interfering with connection to BLHeli32 configurator though.

Only other two things I can think of besides above are re-flashing the Arducopter 4.1 firmware to the flight controller and starting from scratch, and try another ESC.

I’ll keep working on it until I get it. Whenever I do, I’ll let all know the solution that resolved it.
If anyone has any other ideas, I’m always open to listening!
Thanks again!

Yes, sorry Tom I misspoke. Use of an Arm switch is not uncommon so I don’t suppose that’s related.

You know sometimes it’s hard to see the forest from the trees. You don’t have a FRAME_CLASS defined and there are no assigned motor outputs…

1 Like

I had a similar issue with Plane here:

If Copter uses a SCHED_LOOP_RATE of 400, maybe try setting SERVO_DSHOT_RATE to 5, which would give you an output rate of 2kHz.

You could also try setting SERVO_BLH_OTYPE to 6 to set motor outputs to DSHOT600 even if they’re not identified by the automatic motor mapping.

That will be the problem!!

I just flashed from plane to copter and got a frame type error when powering up. Don’t recall that. I just clicked on the quad frame one more time and it worked fine

When firmware is flashed for the 1st time FRAME_CLASS is unassigned and you will get a Frame: UNSUPPORTED message.

It’s also the reason some people complain that the full parameter list is missing some descriptions. Select a FRAME_CLASS, reboot and they magically appear…

1 Like

Thanks Dave, that’s interesting.
I did have the frame class & type set, however, I did that using a different (latest) version of Mission Planner.
I was having difficulties with that version. so I switched to the 1.3.74.
Perhaps when I switched versions and made changes to other parameters then “wrote parameters,” since i had not set it up with ver 1.3.74 MP it over-wrote what I have previously setup on the other version?
I had not setup any SERVOx_FUNCTION (motor outputs?) because I had SERVO_BLH_AUTO =1. I thought that setting was supposed to map the motors automatically when using BLHeli32 ESC.
In any case, I have now verified the frame class and type (Quad, H) are setup and I’ve got the Servo Outputs mapped as in the image below. This mapping is for a “reverse spin direction” motor setup from that of a “normal X configuration.”
Having verified frame class & type and servo outputs AND changing ARMING_CHECK=0 (disable al), I am still getting the same results as before. Nothing has changed. I’ll be working on this all day today to get it right!

You should have 1.3.75 and then load the latest Beta version from the button on the Help screen. Get in the habit of updating to the latest Beta often.