Dshot Not Working

Hi Folks, Second Post (after extensive reading on all the Dshot extensive Dshot documentation on Ardupilot Home and Discourse, a stupensous job!)
DShotESCs are just not getting recognized
Build: Cube Orange, MP 1.3.80 - build 1.3.8479.20539 - Arducopter V4.4.0(502702df) - Here3 GPS. 20A Favorite LittleBee BLHELI_s.

Since Dshot is not supported on MAIN Outputs and Aux1 does not support Bidirectional Dhsot, configured Servo10_funtion to Servo13_Function to 33-36 for Motors 1 - 4

ESCs were updated using to BLHeli_S Dshot with Blue Jay using the esc-Configurator. Screenshot of the succesful firmware below

mot_pwm_type to 6 from 0 for Dshot600

I bench tested the ESCs using Pixhawk 2.4.8 (using Pixhawk1 Firmware) in Dshot mode and was able to spin the motors using the Motor test.


Attached are the params for bench test and cubeorange. Any Ideas?

PixBench.param (16.4 KB)
Sep12_2023_Cube_Orange.param (17.5 KB)

In those parameters you still have Servo1 through to Servo4 set as motor outputs, the same as Servo 10 to 13.
In MissionPlanner go to the Servo screen and set Servo 1 to 4 as none, then reboot the flight controller.

Also set

After that you should see something like:
RCOut: PWM:1-9 DS600:10-13
in the Messages tab.

Hi Shawn,

Thanks very kindly for the prompt response. I cannot imagine how I missed the Servo1 -4. Sorry about that. I did fix it and SERVO_DSHOT_ESC,2. It did not resolve the issue. I do see

RCOut: PWM:1-8 DS600:10-14

I just did a file compare of the bench test and Cube file and found that bench had the following parameters (I think I modified them as I was trying the bdshot). I made the same change in Cube. No go.

My UBEC is in AUX 1 and the ESCs in AUX 2-5. It was the same set up in my bench pixhawk1 (2.4.8). (Also, my cube was flying with opto, non-Blheli_S ESCs with the power coming form 5V BEC in AUX1). I am trying to rule out any power issues here.

Still getting "Failed to read ESC) on ESC Configurator - for Bluejay, BLHeli_S and AM32 (esc-configurator.com)

I don’t think it’s quite true that bdshot is not supported on Aux1. Rather, it’s passthrough configuration that can be problematic on that output (on a Cube Orange), but sometimes even that works!

When attempting to configure with passthrough (as it seems you are), be sure to fully power the ESC with a battery and enable any hardware safety switch that is present (or set BRD_SAFETY_DEFLT=0).

Hi Yuri_Rage,

Thanks for the input. BRD_SAFETY_DEFLT=0 for my Cube as I have Here3 GPS, so safety switch is not required and the above stated parameter is defaulted to 0.

Your post made me realize that I had not stated my objective. I actually wanted to test the motors with the Blheli_S supported ESCs on my cube. At the default 5% throttle, Motor Test failed. So I thought perhaps I should just increase the throttle % in the Motor Test which I did from the default 5% to 15% and Volia! All four motors spun! (one motor sounded a bit more guttural which I will change, thoughts?)

The question remains that for the Cube, the ESC reading fails on the Blue Jay web based ESC configurator. Also, the Blheli_s ESCs show no parameters in the Blue Jay Desktop client ESC Configurator. Whereas on my bench Pixhawk 2.4.8, running Pixhawk1 firmware consistently shows the parameters for the Blheli_s ESC in both the web based and desktop Blue Jay configurator. Wonder why?

FYI- My application will be a multi rotor where the autonomous mission will be loaded on a 450 size quad. I will be adding a front and downward facing LiDAR that will fly in vineyards. It will have a sound device that will make predatory bird sounds to scare the birds that are the bane of vineyard farmers. This will elemosinate the canon sounds that scare the dogs and annoy the residents. I am not an engineer, only an incessant and unrelenting enthusiast who would like to learn the platform, perhaps write a few Python scripts for autonomous missions and help out our vineyard keepers.

Is Blheli_s, specifically bidirectional Dshot useful for my application? I have read some posts that show that Blheli_s, specifically bdshot are not that useful for bigger quads, as much it is for smaller racing quads.

All suggestions are welcome and all help is deeply appreciated.

Not true. Bdshot enables the best reference for the Notch Filter for any craft.

Thanks Dave. Notch Filter was the reason I disassembled my working quad.

Do I need to tune before installing the bdshot firmware for CubeOrange for the Notch Filter?

The existing parameters will copy over. You will need to configure the bdshot specific parameters of course.

My apologies I was not clear. I have not yet flown with Blheli_s ESCs and taken no steps to tune the quad. Should I first review the vibrations and take steps to reduce the vibrations before I install bdshot firmware and configure bdshot parameters. Or should I proceed with installing bdshot firmware and invoke notch filter and do the tuning afterwards.

Install the bdshot firmware and advance thru configuration and tuning normally.

Hi, To my knowledge BL Heli_S doesnot support with Ardupilot and configuration through Blheli configurator. You may need to try these with other FC like Naze32 or any other or BLHeli_32 ESCs.

BLHeli_S works fine but is a little timing sensitive.

@Asim can you send the output of "ftp @SYS/timers.txt- " from mavproxy? Also CubeOrange groups are 9-12, 13-14 so you should really set all of 9-12 to dshot if you are going to use them

I have also recently had a problem with the Orange Cube+ and Dshot. I found that the black carrier board was made after the dshot protocol was introduced and is not supported through more than 2 or 3 channels reliably. If you are trying to make a multi rotor you might need some kind of filter or amplifier applied to make sure your signals are coming through clearly. I tried friguring this out for a few days and switched to pwm (big compromise, but it worked).

Which carrier are you using? I don’t recall this issue ever cropping up.

Which channels did/didn’t work?

The standard black carrier board that came with the orange cube +, and I have tried channels 1-4 and 9-12. I had an electrical engineer at my work look at it and he said these older boards can’t do much current output through the signal channels and it’s so low that the dshot will not come through clearly. I could only get 3 of 4 of the ESCs to initialize properly and the last one would sit in a state of “no signal”. If I rebooted like 30 times I could sometimes get the last one to boot, but after arming it would revert to “no signal” as soon as throttle is applied.

Which firmware version(s)?

That doesn’t sound quite right. 9-12 at a minimum should work fine. I use the ADSB carrier on all of mine and have no issues with DSHOT or BDSHOT on the aux channels.

Hi Dave,

Thanks kindly. Will do. Would the options below work for installing bdshot firmware for cubeorange?

Indeed. Thanks Dave!

What you highlighted is Traditional Helicopter. Get in the habit of downloading the .apj file from the repository and use Load custom firmware to flash it. I don’t let MP select what I want.
CubeOrange+ Bdshot

I am using 4.3 and have since given up on this after an EE said that this wont work with the cube orange plus on the stock ADSB carrier board. I don’t know if it is just because the ESCs require a higher power signal than normal or not, I am using the APD F120 V2 ESCs.