Dshot Not Working

Definitely abnormal behavior. Countless vehicles use DSHOT with that carrier board. In fact, I strongly suspect that Cube Orange/Orange+ DSHOT support was developed using that board.

I think we’d see all kinds of systemic issues if the signal lines on the Cube ecosystem were operating so close to a current carrying threshold that the protocol in use could change behavior.

1 Like

Yeah, I hit my head against a brick wall for about a week and a half trying to figure this out. Never got it to reliably work, but when I discussed it with an EE who works with me this is the conclusion he came too. I have since tried again and seen the same failure. The board won’t power the ESCs signal input well enough to support the use of 4 of these ESCs.

I suspect either a wiring issue (maybe inconsistent or even floating ground) or a bad carrier board. Have you tried a replacement?

Yeah I tried a completely different system and saw the same issue.

That’s definitely abnormal behaviour for a Cube Orange and any carrier board.
The carrier board just passes through all the servo connections as far as I know, and all the real I/O and signal conditioning hardware is in the Cube itself.
PWM and DSHOT signals dont really have a different voltage or current requirement - PWM is just groups of oscillating signals at different frequencies - DSHOT is an actual serial data stream, similar to RS232 or others.
The carrier boards usually just have some power-related electronics. The later ones have the ADSB receiver instead of a Serial5 connection.

Like Yuri says, there’s either a wiring fault, or something odd about your ESCs.
There might be some parameter fixes required, but that’s usually a go/nogo sort of thing.
At minimum an ESC should still work with PWM out of the AUX ports.

In MissionPlanner, Messages tab you should get a message something like:
RCOut: PWM:1-8 DS600:9-14

Let us know if you want to pursue this further - it’s worth having DSHOT and the data it can provide.

I checked to make sure I wasnt dreaming - the non-inverting level shifting chip that is the protection between the processor chip and the outside world can do up to 5.5 volts and 50mA per pin (total 100mA all Aux pins combined) - which is enough to run a whole bunch of LEDs, or hundreds of ESCs at once.
The chip that does the same job for the Main out pins has similar ratings.
And they are in the Cube itself.

1 Like

@Yuri_Rage , @andyp1per @dkemxr ,

Firstly, thanks for all your great and prompt replies and suggestions and deep apologies for my tardiness in following through with the suggestions.

The GOOD NEWS is that my Quad is flying using the BLHELI_S ESCs. I have enabled Dshot600 parameters, so my assumption is that the quad using Dshot 600 protocol.

I have installed BDSHOT Firmware. Please see the screenshot below for AP version and Dshot setup:

@andyp1per - I have not used Mavproxy much. But I did install it on my Windows machine and was able to connect to the right com port. I am at this point, per the screenshot. I tried the command "ftp @SYS/timers.txt- " from the Stabilize prompt in Mavproxy which did not work.

I was able to download it from MP->MAVFtp->right click timers.txt and Download. Please find attached. Is this the correct file.
timers.txt (120 Bytes)

I have now enable BDshot parameters as below:
Servos #10-13 being used for Dshot
SERVO_BLH_BDMASK = 7860 (Is this correct config for enabling dsot protocol for motors Aux2-5?)

I tried using @Yuri_Rage 's suggestion for checking rpm values but am not sure which ESC should be used in the Quick Window. I tried all esc_rpm values, ran all motors but did not see the rpm values in the Quick window. Any ideas please?

Here is my dataflash log. This log was captured before enabling Dshot.

Have you loaded Bluejay on your ESCs? RPM feedback won’t work without it

Hi @andyp1per ,

Yes. Please see the screenshot below.

You need to set the output using


Thanks Andy.

SERVO_BLH_OTYPE was set to 6
Need to confirm the value for SERVO_BLH_MASK. I had clicked on Channels 10 through 13 as my ESCs are connected to AUX 10-13, which gave SERVO_BLH_MASK the value of 7680. Is that the correct value please?

Should be ok - if the motors spin then you probably did it right

The motors spin and the quad flies. Here is the proof :slight_smile:
IMG_4398.MOV - Google Drive.

The RPM data does not show against any esc_rpm in “Status” window in MP. I was hoping that BlueJay firmware will allow bidirectional DSHOT. At least for these BLHeli_S ESCs BDSHOT does not work. I will put this on hold and will start tuning, starting with @andyp1per 's “Log Method Tuning”. Great Work Andy! And thanks for all the help!