DShot and BLHeli ESC Telemetry support

Hi all,

I have got this working nicely, both pass through and telemetry. However I am getting a odd limit in RPM. It like I only have 10% throttle. I’m not sure if its a Arducopter setup issue or a BLHeli issue. I am using the same multistar 51A as in the demo.

At full throttle I should be at 8000 rpm or so not 500. It is not throttling up enough to take off. Have tried Dshot150 and PWM both with the same results.

Any ideas?

Had same issue. Disable low rpm power protect on blheli32 suite. :grin:

1 Like

The original issue was due to some odd thing that went away when I flashed master, the rpm limit was with no props on. Once I was on master I could then throttle up to full with no props but not with then I discovered the low rpm power thing so I could get full with props. Flys nicely know.

I’m still not sure what was going on originally but what ever it was has now been fixed.

1 Like

@iampete how are those 51A ESC’s working out for you?

@tridge and I both had issues with them last year, and I currently have about 10 of them dead on my bench. Caused 2 crashes last season, and their telemetry or something caused my flight controller to reboot mid-flight (with no warnings or explanation in the logs).

that is worrying, that have been fine so far. I have flashed the latest blheli and they are somewhat over rated for my hex, it draws about 30A total when hovering. Although I haven’t put a huge number of hours on them yet, probably only one or two. The telemetry is very nice to have, they were the cheapest 6S esc’s I could find with it.

8s?! I thought they were only 6s…

I don’t know what the problem is with them, this post matches my experiences with them perfectly https://www.rcgroups.com/forums/showpost.php?p=39783841&postcount=2771. Browse that thread for a few more valuable posts about them. Somewhere there is a video of the octoporter crashing during low-altitude hover.

I had about 40 hours on my first set before a crash. Then another 25 on the next set before a crash. My latest ground tests lasted about 2 hours and luckily my latest failure happend just before takeoff. I guess I was denying that it could be the ESC’s, but I just found the posts in the link above giving corroborative evidence.

Yeah they are, typo, I guess i’m saving up for some new esc’s then

edit: maybe we should change the photo on the wiki

Yeah, I might be able to work on that today. https://shop.holybro.com/c/esc_0483 appear like a good replacements for you.

1 Like

I ended up testing something similar, the Airbot Wraith32 Metal v2. Same MOSFETs and driver, anyway.

It took some tweaking to get it to drive a low-kV motor, but it did have working telemetry on a PixRacer . . . for a while.

I think somehow either the PixRacer RX pin burned out, or the ESC TX pin burned out, because the telemetry stopped working. The ESC still works, though. I liked this one because I figured the current would be better calibrated thanks to the Allegro hall effect sensor.

@Naterater Have you found an ESC that seems to work reliably? Or not since the trouble with MultiStars?

I’m putting more eggs in the TEKKO 32 metal (very similar to the wraith 32 metal) category. They’re not fully tested though.

Your burnt out telemetry sounds like it could be from this problem.

I had two crashes (second one yesterday) due to midair freezed F405-Wing Controler with the 41 ampere version of this ESC associated with DSHOT + Telemetry.

This is a bigger problem than I thought. I’ll bring this on the Dev Call tonight to see if anything can be done. At minimum, a warning should be put on the Wiki.

If it is of interest, here is the video of the “freeze” flight:

That’s about exactly what happened to me, except both on takeoff and immediately after commanding a turn (so control surfaces were stuck at extremes). The FC won’t initialize unless it is still, so you never get servo outputs to control where it is going.

I’m so glad you guys talked this through. I bought three of the 41 amp versions, and after reading this, I bench-tested one at full throttle (33 amps) and control movements periodically, and it got somewhat hot, but lasted all the way through the first battery. Heaving a sigh of relief, I went to bed. This morning, just before the maiden, I tried a thee-minute full throttle test on the bench, and it failed. crashed my FC as well.
It’s of course in the bottom of everything.

Follow-up: no freeze anymore with exchanged ESC

After two midair freezings with the Turnegy MultiStar 41A BlHeli32 (occured midair without warning after 2,5h resp. 1,2 h of total flying time) I threw the multistar where it belongs into the trash and took the wraith32 metal.

After now 7.5 hours of trouble-free flight time with the Wraith and otherwise identical aircraft / electrical system (ASW 28, Dshot-150, ESC telemetry enabled, F405-Wing) I do not assume that a freezing occurs again.


1 Like

Just discovered this thread. Has there been any discussion or code changes to allow a mid-air reboot under conditions like this?


I’ve brought it up, but it’s never been a priority for the dev team.


Better wording might be, “The dev team is incredibly stretched so while handling mid-air reboots has been discussed, it’s never reached the top of the to-do list”. BTW, Tridge actually has been looking into mid-air reboots recently for Plane. It’s tricky though and it’s very very rarely required.

In any case, I suspect we are talking about different things here. Handling a mid-air reboot of the autopilot is not what’s being requested here is it? The discussion about a lockup is related to these specific ESCs locking up not ArduPilot.

I respect that the dev team is working on other issues, but we are talking about autopilots rebooting here… NOT just ESC’s.

In addition, there’s language to suggest that manual control of servos is possible on planes in the event that the main thread stops (that’s the whole point of the pixhawk’s co-processor). Unfortunately that functionality is unavailable during the reboot sequence that can never complete (because the plane is in motion). To have ANY servo outputs, the plane must be still to complete the initialization phase.

I’ve lost thousands of dollars of commercial equipment due to this, and I can’t afford it again. I’ve had two specific instances where this happened, and it’s been corroborated by many people including Tridge on the octo porter.

1 Like