Dronekit installation issue

Hi there !

I’m trying to install drone kit on my Raspberrypi.
I’ve tried every instruction and pre installation as defined on the web. Still i get this error everytime i execute the dronekit installation command.

Anyone knows what to do ?

Its been a long time I have tried, so I just downloaded the lates 64 bit image and pip dronekit = it worked right away

pi@raspberrypi:~ $ python
Python 3.9.2 (default, Feb 28 2021, 17:03:44)
[GCC 10.2.1 20210110] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

pi@raspberrypi:~ $ pip install dronekit
Looking in indexes: Simple index, piwheels - Simple index
Collecting dronekit
Downloading https://www.piwheels.org/simple/dronekit/dronekit-2.9.2-py3-none-any.whl (56 kB)
|████████████████████████████████| 56 kB 326 kB/s
Collecting monotonic>=1.3
Downloading https://www.piwheels.org/simple/monotonic/monotonic-1.6-py2.py3-none-any.whl (5.3 kB)
Collecting pymavlink>=2.2.20
Downloading pymavlink-2.4.29.tar.gz (5.2 MB)
|████████████████████████████████| 5.2 MB 6.8 MB/s
Collecting future
Using cached https://www.piwheels.org/simple/future/future-0.18.2-py3-none-any.whl (491 kB)
Requirement already satisfied: lxml in /usr/lib/python3/dist-packages (from pymavlink>=2.2.20->dronekit) (4.6.3)
Building wheels for collected packages: pymavlink
Building wheel for pymavlink (setup.py) … done
Created wheel for pymavlink: filename=pymavlink-2.4.29-cp39-cp39-linux_aarch64.whl size=5390544 sha256=e7505b2add9fe079487ea48bb32e0dbaa21b5ab9d794decb4713a31862afc904
Stored in directory: /home/pi/.cache/pip/wheels/d0/18/ad/cbd1a5ab8cc292c6dc04c1016c163c23b3b62a1096ff8f4790
Successfully built pymavlink
Installing collected packages: future, pymavlink, monotonic, dronekit
WARNING: The scripts futurize and pasteurize are installed in ‘/home/pi/.local/bin’ which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed dronekit-2.9.2 future-0.18.2 monotonic-1.6 pymavlink-2.4.29

1 Like

Name resolution error.
Seems like you have a misconfiguration on your name server settings or servers might be down.
This is nothing to do with the dronekit.

1 Like