Dronekit connect not working on raspberry pi and pixhwak

Hi Dear,
I am running dronekit on raspberry pi with pixhwak connection. but am getting an error also with connection (wiring) mavproxy working fine.


pi@raspberrypi:~ $ python3 drone.py --connect /dev/serial0 --baud 57600
connecting to /dev/serial0
CRITICAL:autopilot:PreArm: Throttle below Failsafe
CRITICAL:autopilot:PreArm: Hardware safety switch
CRITICAL:autopilot:PreArm: Battery 1 low voltage failsafe
CRITICAL:autopilot:PreArm: Board (4.1v) out of range 4.3-5.8v
Traceback (most recent call last):
  File "drone.py", line 14, in <module>
    vehicle = connect(args.connect, baud=args.baud, wait_ready=True)
  File "/home/pi/.local/lib/python3.7/site-packages/dronekit/__init__.py", line 3172, in connect
  File "/home/pi/.local/lib/python3.7/site-packages/dronekit/__init__.py", line 2375, in wait_ready
dronekit.TimeoutError: wait_ready experienced a timeout after 30 seconds.


from dronekit import connect, VehicleMode
import argparse

parser = argparse.ArgumentParser()
args = parser.parse_args()

print("connecting to", args.connect)
vehicle = connect(args.connect, baud=args.baud, wait_ready=True)
print("Connected to vehicle")

Please try to help me.
Thanks You!

the baud rate should probably be 115200

No Sir. If I set to 115200 then it shows heartbeat not received

And it working now. I reseted all parameters via mission planner > config > full parameter tree