Drone drifts in random directions on take-off

My diy drone drifts in random directions during take-offs. All the pre-flight checks are okay. I have tried taking off in stable mode and loiter mode. Regardless of the mode, the drone wants to drift away.

I have included the log of my flight this morning. As I am a noobie, any assistance is much appreciated.

2019-08-11 09-09-30.bin (540.0 KB)

You’re going to need to learn how to use the transmitter.
The reason you are seeing drift is because you are not in a GPS guided mode.
You did not wait for the GPS to settle and therefor your switch to Loiter was refused, as you only had 3 sats at the time.

Always check your flight modes BEFORE you arm, as you will be able to hear the refuse beep, and see the yellow warning LED.
Motors 2 and 4 seem to be working harder than 1 and 2.

Thank you all for your help. Any suggestions regarding the discrepancy between load on the different motors? I calibrated the ecms.

That different load on motors is caused by physical balance centre of gravity.
Motors 2 and 4 working hard mean most of the weight is to the rear of the copter and it should be moved more towards the center or front - or add more weight at the front if your thrust will support it.

Thank you for the response. I realized that I had the battery too far aft. That adversely affected the cg which was why engines 2 & 4 were working harder. So now I know to let the drone acquire a good gps signal and have proper cg.

Again, thank you to all took the time to review my flight log and respond.

Yeah, switch to loiter mode while still on the ground and see if you’ve still got a green LED, our if it’s rejected.
If you’ve got a ground station or OSD look for a HDOP of less than 1.0. Don’t necessarily look for number of sats.

Thank you for your help. I moved my battery to the center of the drone and that solved all my problems. I had three excellent extended flights. As I am new to flying drones, is the loiter mode a good mode to learn how to control the drone?

Yes loiter is a good mode for learning how to fly with drones because copter will keep altitude and its position automatically
But you can only fly with loiter in outdoor with a gps lock and hdop lower than 1
Also try loiter with super simple mode for a better fly experience

I disagree.

When you are “flying” in Loiter or AltHold, the firmware puts a “dead band” around throttle. This causes a significant lag in throttle. As a result you can get into an “over control” situation. Another issue is flying in AltHold when you have not enabled Hover Throttle Learning will give you a false “muscle memory” of where hover throttle is.

My recommendations:

Learn to fly in Stabilize mode.
Turn on Hover Throttle Learning.

On your next flight, BEFORE YOU ARM THE MOTORS, use Stick Gesture (Throttle FULL High, YAW FULL Right) to start Compass Calibration. This will generate compass off sets for your flying site. If you change sites, re-calibrate the compass before you fly.

When Compass Calibration is completed, REBOOT Pixhawk (disconnect and reconnect the battery).

Arm the motors and run Auto Trim. This will give you a much better hover.

At this point you can take off in STABILIZE and the aircraft should ascend straight up. Establish a 10 foot hover and switch to AltHold. With hover throttle learning enabled, Pixhawk will start to learn where Hover Throttle is and set it to MID THROTTLE STICK where it belongs. This becomes your muscle memory “anchor point” for hover throttle.

1 Like

Both are correct. To get a drone flying correctly the drone needs to fly well in stab mode first. Stab mode should be your goal a a beginner pilot but do not switch to stab if you are not an experienced pilot. To get to the point where stab mode is 2nd nature, loiter and alt hold are your friends. There is no reason that you should not learn to fly in loiter first. That does not mean test a drone in loiter first. Get someone to help you to make sure stab mode gives proper stability & control. Then learn to fly at you own pace.