Servers by jDrones

Drone does not hold position in loiter mode

intel-aero-rtf
arducopter
quadcopter

(Soubhi Hadri) #1

Hi All,
I have RTF drone. I did many tests on it and it was good. Today when I was working with it, it was not able to hold position in loiter mode. How can I debug the problem? I tried many times.
Here are two logs:
https://drive.google.com/file/d/1vJalq9tYA-6o99mbkcftlA5C0AJAl1-P/view


(Mike Boland) #2

You have not said which log is the good flight and which is the bad.
You are running 3.6dev firmware for a start.
Not recommended or encouraged for new users. You should be running a stable branch, such as 3.5.4 at present.
Maybe someone on the forum knows why the Intel Aero RTF is delivered with 3.6dev?

Did you do a compass calibration?
Even an RTF drone will need a compass calibration.
And you will need to do a compass calibration when you change flying sites.
First step is to learn to fly it in Stabilise.
That way you will know how it handles and if everything is working well.
There is quite a bit of vibration building but the flights are too short to draw any conclusions.

There is a divergence in desired and actual roll and yaw.
Has this copter been tuned?

A longer flight log while in stabilise might help someone to see more of whats going on.

There is quite a discrepancy between motor outputs.
Do you have the correct props on the correct motors?
Check your motor and prop setup.


(Soubhi Hadri) #3

Thank you for your help!
Actually I have been working with drones for months. I re-calibrated the compass before the flight but not in the same place ( I did the calibration inside my lab in building beside the flying area). Both of the logs for inappropriate flights and they are not long because the drone started moving and I had to land it. Recently I changed the propellers (I am sure I set it in correct way because it is not possible to set it wrong).
Recently, I also added guards for the four propellers.

What do you mean by tuned?

thank you


(Mike Boland) #4

All setups need some degree of tuning as the PID settings supplied as default are only estimates.
Enough to get you flying so a simple autotune will fine tune the PIDs for you.

You said this was an RTF copter.
I would have hoped it was already done but I am doubting it.
have a look here at Autotune


(Soubhi Hadri) #5

Yes, it is auto-tuned because I did many successful flights during the last months but no suddenly it is not able to hold position and I do not know exactly what the reasons.


(Andrew Challenger) #6

When you say it won’t hold position how does it behave? Does it drift slowly with the wind? Takes off in a random direction?

I’ve had issues with ekf variance/compass health that have prevented my copter from entering proper loiter, instead it switches to althold when I try. Landing, powering off and restarting the drone fixed it for me, maybe unplug/replug your compass/gps connections to make sure they aren’t getting loose?


(Mike Boland) #7

Yes, as @FlyingPotatoes mentioned, if you want detailed answers you need to give us as much detail as you can.

Many successful flights does not mean it’s tuned, it could just mean you have been lucky till this point.

I have also had issues with EKF where a bad compass connection (faulty I2C splitter) caused to the copter to fly off in different directions when switched to Loiter, or so it seemed.
When given enough room I eventually saw that it was just a huge toilet bowl effect which instantly drew attention to a bad compass, and eventually the connection.


(Soubhi) #8

Ok, I will try to re-calibrate the compass in the same area and fly again and tell you what will happen


(Soubhi Hadri) #9

I replaced the GPS-Compass module (in case it is damaged).
I re calibrated in the place of flying but the same results.
This is a short video about the last flight. I took off in loiter mode.
https://linksharing.samsungcloud.com/1515456450552Cw5YxlY


(Mike Boland) #10

Can you post the log file from that flight please.


(Soubhi Hadri) #11

I am not sure 100% which one is for the flight in the video. I think it is 00256-2017-04-23_06-07-49.
Anyway, in both I was not good and went crazy.
logs.

thank you


(Mike Boland) #12

The first step in sorting any copter out is to fly it manually to make sure the basics are working before expecting guided modes to work.

Have you flown it in Stabilise?


(Soubhi Hadri) #13

you are right but I am not a good pilot in Stabilize mode. I find it a little bit difficult.


(Andrew Challenger) #14

I hear you there. Flying a multirotor without GPS assist is not as easy as youtube makes it look.

If you plan on flying for any amount of time though I’d really encourage you to invest the time in practicing stabilize flight, being able to switch into stabilize and manually recover from an impending crash is essential. It’s saved my bacon more times than I can count, often with only a second or two to spare.

It’s way too easy to accidentally enter an incorrect altitude on a waypoint or get blindsided by a GPS failure in a tight space. Having stabilize mapped to a single switch, eyes on the bird and thumbs near the sticks is the only defense. :frowning:

If you’ve got the budget, buying a cheap crashable quadcopter is a great way to practice.


(Matt) #15

Well first things first, compass calibration needs to be done outdoors, not inside a building. It needs to be done away from structures, vehicles, reinforced concrete slabs, steel fencing, and other sources of magnetic interference. And you need to not have sources of magnetic interference on your body, like magnetic jewelry and accessories.

Compass calibrations does not need to redone at every new flying site. It only needs to be redone if you’ve reconfigured the copter, added/removed hardware, done a parameter reset, or it otherwise asks for it. Or if you didn’t do it right to begin with :stuck_out_tongue:. You should definitely NOT be redoing it every time you go somewhere else to fly.

Also make sure you did the accel calibration correctly. It needs to be perfectly still in each of the prompted orientations when you press the key. So it needs to be done on a solid and stable surface like a floor or table. You can’t just hold it up in the air on it’s side.

Beyond those things, vibration will ruin your loiter. I can’t open the logs at work. But that’s the next thing to look at in the logs after you have done your calibrations correctly!


(Soubhi Hadri) #16

Thank you very much. I did the calibration out side in the same place of flight. Today I noticed that the drone always goes in right direction when it should keep its position. I tried stabilize mode (I am not a good pilot in that mode) but I did not notice that much of shifting to right (but again I am not sure in this point). I changed the GPS&Compass module in case it is damaged. BTW, this is the second Intel Aero drone that has the same issue and I am not able to fix it.
Please any further suggestions?

Thank you all.


(pradeep kumar) #17

Do you mount the flight controller on an anti vibration pad? Vibration can make loiter to behave unexpected.


(Shawn) #18

Level horizon - this will help drift, assuming all the props and motors are all nice and true.

I made a lightweight aluminium level from some “angle” and a brick layers line bubble level. A normal level is too heavy and cumbersome. It sits across the top of the motor shafts one way then the other and you get your craft PERFECTLY level before pushing the level horizon button in GroundStation soiftware or there’s a way to do it on your transmitter.
Hold disarm for 15 seconds to level horizon via transmitter stick combo.
http://ardupilot.org/copter/docs/troubleshooting.html#my-copter-moves-in-a-direction-even-though-the-stick-is-centered


(Soubhi Hadri) #19

Yes. It is RTF so the flight controller is implemented above anti vibration pads


(Soubhi Hadri) #20

Hi All,

Until now I am not able to figure out the problem and these are what I did :

  • The propellers are good because I tested it on another drone and it holds the position and altitude in loiter mode.

  • I change the compass&GPS module and did the calibration for compass outside in the same area I did the test, but the problem still appears.

  • I re-flash ardupilot 3.5.4 and went through the whole process (calibration).

  • I checked the flight controller and it does not vibrate. It is well fixed.

  • I did many flights in Stabilize mode and It was good. It is even better than loiter mode (in loiter mode it shifts alot). Whenever I switch to loiter or land mode, it shifts and crashes.

Any other suggestion :confounded:

Thanks you