Drone Crashed while doing loiter speed about 7m/s or in normal winds

Hi, Everyone.
I have a drone, having 30 inch propellor in H configuration.
Whenever i tried to manuver it in Loiter mode the drone get wobbled up and losses its altitude. Resulted in crash. I have tried Harmonic notch, Autotune but i am facing the same problem.
I am attaching the param file and graphs for the same below.
@dkemxr @xfacta @tridge

kartik_param.param (18.3 KB)

Update to ArduCopter 4.4.4 and follow from the very beginning every single step:
Methodically tune (almost) any multicopter using ArduCopter 4.4.x

After that, post a new .bin log file here. We do not need a .param file.

Similar is in my case. Below are the logs attached.

My firmware is 4.0.4 and due to my client, i have to use this version only.
Can you look into it. As i have almost crashed 4-5 times. My drone is just not handling the breaking of loiter mode and moderate winds.

You ask me to look at logs, I ask you to read a document that explains how to properly configure the vehicle, and ask questions later. (BTW most of the document is applicable to ArduCopter 4.0.4)

You ask for fish, I try to teach you fishing.

Looks like a stalemate. :slight_smile:

Thanks @amilcarlucas for prompt reply.
So, from start what i have done is as per the document and reached the step of autotune, where my drone crashed while doing tuning. After that i have manually tuned it in Alt hold then in loiter and get to this stage where i am now. The drone fly fine while hovering but it is not handling the jerks of loiter and winds.
Can you suggest as per your experience where i am going wrong. If you show me the direction, that would work too.

You checked all hardware best practices from section 1?
Did IMU temperature compensation?
Did magfit flight?
Have low vibe values and a proper ESC based Notch filter configured?
And have tested that the post notch noise is almost non existent?
Before autotune you performed the test flights described in section 5 and 6? with what results?

Yes @amilcarlucas i have done the hardware check. Then IMU compensation. Mag fit.
After doing notch filtering the graph become negligible. Firstly, the values were in 2 digits then after filtering the value come in range of 0.00xx range.
After that i have started autotuning with aggression 0.075 but the twitching was scary so reduced it to 0.05 then Roll tuning was done and pitch tuning started and after 2 twitching the drone crashed. So, i started manually tuning it and here i am, when i do roll and pitch at same position it reacts well but when i start moving it and stop it wobbles at even 5 m/s.
I am stuck at this now. Kindly help.

Before autotune you performed the test flights described in section 5 and 6? With what results?

Vibrations are too high. Fix that first. In fact don’t even read anything else until the vibrations are fixed. Don’t do an autotune until the vibrations are fixed.

Rate outputs (the ones that @amilcarlucas asked you to check in steps 5&6) are too high.

Why are you using EKF2? You should probably switch to EKF3.

Update your firmware. 4.0.4 is old.

@Allister can you check graph of my drone that I have shared across at the start of this thread. In my drone, vibes are not there but still the same is happening as in @AmitSingh

@xfacta @amilcarlucas @dkemxr Please help.

Have you done all steps per the previously linked instructions? If not, there’s no sense tagging everyone under the sun…

1 Like

You only posted parameters. As stated above, you need to post a .bin log file.

I will fly tomorrow and share the same.
There is one doubt i have, my drone is light as per the propellers, so when wind comes, the motor rpm reduces due to which i have observed that the drone loses its altitude and stability.
Which parameters can help in those situations?

You need to start at the beginning, read the document, those problems are addressed on section 11 of the document. But you MUST do sections 1 to 10, before doing section 11.

And stop trying to find shortcuts. There are none.

The Copter 4.0.4 was released on 16-Sep-2020. With a lot of fixes since then, the developing company should educate the client for a safer and lower-risk flight for the good of the client and the community below the air vehicles.

The tool is unable to extract the default parameters to trace your changes to better narrow down the causes.
/extract_param_defaults.py 2024-01-30\ 04-24-04.bin -s missionplanner > defaults.param
The .bin file contained no parameter default values. Update to a newer ArduPilot firmware version

I urge the company to have serious consideration to move to the latest firmware.

sure. I will do the needful.
@cartik2000 Just start from the basics, you might be missing something very basic.
Follow the suggestions of @amilcarlucas

1 Like

I have one doubt, does the PSC parameters works only in loiter or they work in althold also ?