Dodeca Hexa – only 10 of 12 Motors get a Signal

This is a re-post of Dodeca Hexa with “Flier OPTO ESC” – AUX Output Channels are not working correctly

It seems like that the interest on a Dodeca Hexa Frame with a specific Flier ESC is very low.
But I am still sitting with the problem. This is why I try it with this new post.

In this post I will concentrate only on the main problem: “only 10 of 12 Motors get a Signal”
(the wrong motor number allocations I can change in the settings. Not the right way, but it works)

I organized an oscilloscope to be able get some facts:

On 10 of 12 outputs of my flight controller (Cube 2.1) I am getting a perfect signal:


These motors are also working as expected if I perform a motor test

On 2 outputs I get no signal at all:


I tried all scenarios: motor test, armed and live…
(with connecting a servo tester instead of the FC connections: it works!)

It could be a software problem (which I believe) or a hardware problem. But I really have no idea how to find it out and how to go ahead. I need assistance in any case: Hardware or software…

Important note: These signals (the good ones and the bad ones) I am getting in all test environments: Disarmed, armed and motor test. It really can’t be a wiring problem, because if I am using a servo tester, the 2 problem motors/ESC’s are working perfectly.

I hope to get with this post some more attention and hopefully somebody have an idea what could be wrong. I strongly believe in a firmware problem. How can I bring this to the attention to a developer?

Thanks in advance


Whats your BRD_PWM_COUNT param?

Depending on how you have it wired up you may have to change it, 8 main and 4 aux would need BRD_PWM_COUNT to be 4. 6 aux and 6 main it would need to be 6.

We will need logs to give better advice.

1 Like

Hi Peter, I will look into it tomorrow and check the BRD_PWM_COUNT!

Regarding the logs: Thanks for the advise. With my results of checking “BRD_PWM_COUNT” I also will include it!

Dear Peter: Bingo! You helped me again. Thank you so much.
BRD_PWM_COUNT was on 4, this is why AUX 5 and AUX6 gave no PWM out. When I changed it to “6” there were no change (after reboot). AUX 5 and AUX6 give still no PWM out, but I get the signal on MAIN7 and MAIN8. I will just change my wiring.