Dodeca Hexa Copter - Set up via Parameter List - Getting Error Message "PreArm: Check firmware or Frame_Class"

I just moved from QGroundControl to Mission Planner. Main reason is the motor test function in Mission Planner. I first started with QGroundControl because I could not find my frame type “Dodeca Hexa Copter” in Mission Planner. I got an advice in this forum to change the parameter Frame_Class (in the Full Parameter Listing) to the value of “12”. I did that and I also changed the parameter “Frame_Type” to 3 (which is H").

I don’t get it working. I am unable to arm the copter motors I am getting all the time the same error:
PreArm: Check firmware or Frame_Class


Dodeca Hexa’s dont have a H frame type, only + or x (0 or 1)

Upps, I never thought about that! I will charge it an post the results!

Thanks Peter…, you are right! I don’t get the error anymore. But I hope one day there will be a Dodeca Hex in H configuration added :wink:

how can i add dodeca hexa with H frame configuration ??

You can take a look at the Pull request that added the dodeca, and change it a bit.

After that create a pull request for review.