DJI F450 ESC calibration fail

Hi, everyone. I am building a DJI F450 clone. I’ve got everything attached except for the propellers. The Pixhawk connects to my mission planner via USB. The remote controller is paired with the drone. Now I need to calibrate my ESB. Unfortunately, this is not working. The drone seems not to be going into calibration mode. It just blinks yellow and beeps.

Here is a video of the issue:

Potential problems and fixes I’ve tried:

PWM vs PPM on the remote. I’ve tried it both ways, with no luck.

Power connection is backwards. In the tutorial I’m following, the connections seem to be a bit different from my hardware. I’ve got a female XT60 on my shield, a male XT60 on the battery, a male XT60 on the “in” side of my power board and a female on the “out” side (the one which also has the data cable coming out of it.) The only way I can plug this thing together is to plug the battery into the “out” side of the power board and the shield into the “in” side, as seen in the video above. To test this hypothesis, I made some female-female and male-male jumper cables and tried to connect things the way they are on the tutorial…but no luck, same result.

Issues with the remote. I’ve tried to set the ESC_CALIBRATION parameter in Mission Planner to 3 for automatic calibration, with no luck.

So you have a Mode 1 Transmitter. Hopefully that’s what you want, Mode 2 is more common. On the Radiio Calibration Screen of Mission Planner do the Roll, Pitch, Throttle and Yaw (Aileron,Elevator, Throttle, Rudder) respond correctly when you move these sticks?

Mode 1

Yes, they all respond correctly.

Do the motors operate when you run Mission Planners Motor Test? Just trying to establish if the craft is basically ready to run.

No, the motor test does not spin the motors. When I hit the test button, I hear eight separate beeps, the light on the Pixhawk flashes red, green and blue, and then it goes back to flashing yellow and beeping steadily.

Connecting each motor to the radio control unit directly does spin it.

OK, so forget about ESC calibration if the motors don’t spin in Motor Test. Disable the safety switch from Mission planner for now BRD_SAFETYENABLE (0). Try the Motor Test again at 20% throttle. If this doesn’t work you have something fundamentally wrong. Post your parameter file here.

1 Like

Disabled the safety switch. Set the motor test to 20%. Still no spinning. Here is my file.

MissionPlannerParams.param (17.4 KB)

You have Frame_class at 0 (undefined). Set this to 1 for quad. This is the 1st setting in Mandatory Hardware> Frame Type. This means you have no Servo outputs assigned to motors. And don’t skip the Motor Test, you got ahead of yourself.

Thank you, now I’m getting somewhere. All four motors spin in the right direction with the motor test. But I still can’t calibrate the ESCs. Setting ESC_CALIBRATION to 3, disconnecting and reconnecting the battery results in some beeping followed by a rapidly flashing green-red-blue sequence. Disconnecting and reconnecting the battery again, the indicator is flashing double yellow, and the motors do not respond to throttle input.

Set this back to default 0.

That’s because one or more pre-arm safety checks have failed…

Beside that you must arm the motors, and I would not recommend doing that on the bench with or with out the props on.

Thank you. How can I check to see which pre arm checks are failing? I’ve armed the motors with the switch, which still doesn’t work.

Connect the Pixhawk to Mission Planner.
Navigate to Config > Planner and make sure “Enable Speech” is enabled.
Mission Planner will call out all active fail safe conditions.

Also on the DATA screen below the HUD Click the Messages button. This will open a window that will display all messages sent from Pixhawk to Mission Planner.

On the messages screen accesed below the HUD

Question: Have you actually read the documentation?

There’s a lot of documentation. I’m trying to follow along with an online course which apparently has some gaps. Is there a starting guide you could recommend?

I have yet to find an “on line course” that isn’t bloated with a lot of drivel and blatant advertising, and a good majority are either just plain wrong or way out of date.

You best bet is to start here: and work your way down the list. And if you get stuck come back here.

FWIW, the main problem I see is when someone new wants to do something different but they fail to realize that it either can’t be done, or is won’t work the way they think is should.

A case is point is your initial ESC calibration. It doesn’t work that way. What you should have done was connect Pixhawk to Mission Planner, navigate to Setup > Mandatory Hardware > ESC Calibration and read the instructions under ESC Calibration (AC 3.3+). You do not have to dink around with the RC transmitter.

Its the little things like this that will always jump up and bite you.

Thank you.

I’ve got everything calibrated, the motors spun in response to throttle input during ESC calibration, and I’m now trying to do a test flight. I get a blinking green light, and the computer says it sees 9-10 GPS sats. When I disconnect from the computer and attempt to give it throttle, nothing happens. What should I be checking?

Connect it back to Mission Planner and Arm it (props off) and see what message it’s giving in the HUD or the messages screen.

I connected it to mission planner and attempted to arm it. It says “disarmed”. You can see the messages and HUD in this screengrab.