DJI Air Unit O3 and MSP DisplayPort OSD

Hello, is there anybody who got the Canvas Mode OSD with the new Air Unit O3 working?

Tried these settings with 4.3.1 but no OSD appears.

OSD_TYPE = 5

SERIAL2_PROTOCOL = 42

I also tried MSP_OPTIONS bit 2 to 1.

Latest Firmware on Air Unit and Goggles V2.

Any suggestions?
Thanks

2 Likes

Hi.
Check the following settings and make sure to let them know if they work!

To enable MSP OSD, set the following parameters (example below is using SERIAL port 2 as the port to attach to the DJI Air unit using both TX and RX lines). DJI OSD must be enabled: in SETTINGS->DISPLAY->CUSTOM OSD menu of goggles

[OSD_TYPE] = 3 (only required to obtain statistics information panels). Can be set to 1 if autopilot has integrated analog OSD to use that feature in addition to the MSP OSD feature for DJI goggles.
[SERIAL2_PROTOCOL]= 33
[MSP_OPTIONS] = 0 (polling mode)

Hi Alek, this is correct and working for DJI Air Unit first generation.
This does not for for the brand new Air Unit O3.

the new unit is so brand new that there may not be support yet.

The new O3 Air Unit works for me on 4.3.0 with:

OSD_TYPE = 5
SERIALn_PROTOCOL = 42 (n corresponds to the UART where the Air Unit is connected)
MSP_OPTIONS = 4 (uses Betaflight fonts; without it many symbols are missing)

I also had the following defaults, didn’t change them:

SERIALn_BAUD = 115
SERIALn_OPTIONS = 0

3 Likes

Thanks, i tried it again with your settings. Its working! Lot of Symbols are Missing but better then nothing

3 Likes

In my quad working too! Thank you!

Afternoon guys.

With the DJI o3 / G2 MSP osd working 90% with ardupilot, will anyone work on a compatibility mode for correctly using characters / the compatible map dp set we can use?

Thanks

image

2 Likes

Thanks for posting this. I have my 03 working on arduplane. Does anyone know how we can get the osd moved further to the edges of the screen? With items all the way to any side edge in mission planner, they are actually closer to the middle of the screen as shown in the above screen capture.
Thanks

1 Like

Is there a workaround already for the O3 Air unit? I also don’t have all the OSD items, for example I don’t see the arming status.

I am currently using O3 with autopilot, follow those setting above, I can use MSP display mode to show flight data on my goggles via o3, thanks.
However, 1\ the recording and low power mode exit cannot be triggered while arming , 2\ the voltage of power is not recognized by DJI, it displays 0.0V at the right bottom when serial_protocol is 42 (when =33, power voltage is shown but no other osd data displayed) .

may there be a setting on ardupilot where the O3 can recognize the arming signal?

Update to 4.3.3. problem fixed, thanks