Servers by jDrones

Disable (RC) Throttle Failsafe when airplane is on the ground


(Brian Christal) #1

Is there a way to disable RC Receiver failsafe when an airplane is on the ground. This is really dangerous. If you arm your airplane on the ground and your RC transmitter is off, the airplane will enter RTL and the motor will spin full power. Yes this is desirable if the airplane is flying and loses RC. But it is all to common on the ground to accidentally have the RC Tx off.

Thanks!

Brian


(***) #2

Brian,

If you go to the initial setup tab and select mandatory hardware, then go to the failsafe tab on the right/middle you will see 3 failsafes, battery, Radio, and GCS. Just disable the radio one. Also look in full parameters for FS_THR_ENABLE is set to 0.


(Brian Christal) #3

Thanks! But I still want to keep RC transmitter failsafe. I currently set it to 60 seconds. At some point the airplane needs to come home if there’s RC TX connection - so I don’t want to disable it.


(***) #4

Ahh I see you are asking if there is away to disable the RC FS while it is on the ground, as of right now I am unaware of a setting that allows this, would be nice to say disable the RC FS at altitude of say <0.5m. Maybe someone else will chime in but I don’t think this exists yet.


(Brian Christal) #5

Yep. Altitude, inertia, whatever it takes to not enter RTL if the airplane is not moving. It’s such a problem I print this warning on the motor mount. Not exactly the best solution. -Brian


(James Pattison) #6

Please raise an issue in GitHub.
All users should be turning the RC tx on before powering or arming the aircraft, and have pre-arm checks enabled (which would prevent arming without RC), but I see merit in considering an ‘is flying’ flag for rtl.


(Markus Müller) #7

Doesn’t happen on my plane. Maybe your setup is not correct.
I strongly believe there is only one reliable way to prevent the motor from running and that is - no juice - I simply don’t trust the electronics anymore. For playing around I don’t connect the battery of the motor, I use a small battery or BEC with a valid voltage and connect it instead of the ESC.
Sometimes I want to see what the motor would do and I disconnect one of the three motor cables or remove the prop.


(Brian Christal) #8

Hi James,

Added: https://github.com/ArduPilot/ardupilot/issues/7279

Thanks!

Brian


(James Pattison) #9

Thanks Brian.
A log would be useful for replicating this, as there are already safeguards in place (arming checks etc).


(Rolf) #10

Hi Brian,

I can not replicate your problem (pixhawk 1 arduplane 3.8.3)
Can you please link at least one parameter file ?

Regards Rolf


(Brian Christal) #11

Hi Rolf,

Here’s a screen shot of the log showing RC3_OUT going to full throttle while there is no RC TX connected.
Here’s the bin: http://www.tuffwing.com/support/00000018.BIN
Parameter file attached below.

Thanks!

Brian

Tuffwing_3.8.2_param.param (14.2 KB)


(Rolf) #12

Hi Brian,

you should enable ARMING_REQUIRED.
http://ardupilot.org/plane/docs/parameters.html#arming-parameters

Regards Rolf .


(Brian Christal) #13

Hi Rolf,

Thank you for recommending ARMING_REQUIRED. However, I’m not getting what I think is the expected behavior. ARMING_REQUIRED only forces left rudder input to ARM. Yes, this solves requiring an RC connection to ARM. However, I expected ARMING_CHECK to handle Pre-Arm check. It is set to 1 in my parameter file. That is “ALL” which includes RC Failsafe.

Note in BOLD from the description of ARMING_REQUIRE

==SNIP==
ARMING_REQUIRE: Require Arming Motors
Note: This parameter is for advanced users
Arming disabled until some requirements are met. If 0, there are no requirements (arm immediately). If 1, require rudder stick or GCS arming before arming motors and sends the minimum throttle PWM value to the throttle channel when disarmed. If 2, require rudder stick or GCS arming and send 0 PWM to throttle channel when disarmed. See the ARMING_CHECK_* parameters to see what checks are done before arming. Note, if setting this parameter to 0 a reboot is required to arm the plane. Also note, even with this parameter at 0, if ARMING_CHECK parameter is not also zero the plane may fail to arm throttle at boot due to a pre-arm check failure. This parameter is relevant for ArduPlane only.
==SNIP==

So the airplane should not ARM if no RC connection, right?
Also this does not solve if you turn off the RC transmitter while the airplane is armed and on the workbench.

Brian


(Rolf) #14

Hi Brian,

Last time i tried to replicate it with ARMING_CHECK set to 0 and no GPS. Now i saw that the motor starts just at the moment when EKF begins to use GPS . I will try to replicate it tomorrow…

Regards Rolf


(pradeep kumar) #15

Dear Brain,
I can’t get how you are arming your plane with your Tx off. As the standard procedure I switch on my Tx then power up the plane.
Regards
Pradeep


(Brian Christal) #16

Hi Pradeep,

Yes, “Standard” procedure is to turn on RC TX. But there is another problem. RC TX can accidentally be turned off while airplane is armed, on the workbench. The results are obviously bad.

Brian


(pradeep kumar) #17

Dear Brain,

I am still confused.

My point is, RTL mode save the GPS coordinate where the UAV is armed before any movement. While the UAV is flying if it lost the signal from Tx, it goes to FAILSAFE mode and initiates RTL and returned to the position where it was armed. Now you armed the UAV and still it is on the armed position, and armed location, turned off the Tx (accidentally). Then if RTL initiates where the vehicle will go? It is in the home position already. The motor should not spin! I may be wrong.

Regards,


(IronDOme) #18

RC fail safe kicks in first I think and the routine to check GPS would follow, that is logical I think. I personally never had such an incident, but I think Brian is right.


(Brian Christal) #19

Hi Pradeep,

When the airplane is in RTL:

  1. Its airspeed must be TRIM_ARSPD_CM
  2. Its altitude must be ALT_HOLD_RTL
  3. Home GPS position is not perfect - it is always shifting. It is never exactly in its “home” location.

I’m sure there are more reasons the airplane wants to fly…

Brian


(pradeep kumar) #20

Dear Brain, Ome,

Today or tomorrow I am going to try the failsafe with my drone. I will just create the situation that Brain is thinking about. Let us see what is happening.

Regards.