Dev Call Jan 20, 2025

Vehicle Update

Issues & Pull Request

Attendee count (max): 16

UTC2301 - pre-meeeting

  • Discussion of analytic tuning discussions with Bill
  • Would be great to add Lua SYSID mode for plane
  • Built-in SITL models can be used
    • Heli Autotune was built off the in-built model

UTC2303 - APM_Control: add AP_FW_Controller as common base class to roll and pitch controlers by IamPete1 · Pull Request #27747 · ArduPilot/ardupilot · GitHub

  • Add AP_FW_Controller as a common base class to roll and pitch
  • Now there’s a test which runs a chirp through the system to make sure this is working
  • No change in behaviour
  • Having problems with waf and the example
  • Defines in wscript weren’t nice
    • …. Disabling AHRS disabled it in all of the other examples!
  • Want AP_LIB_EXTRA_CXXFLAGS dictionary
  • Conflicts with MdB’s flap feed-forward PR
  • What happens if we do need to make these different?
    • Virtual functions…
  • Need to
    • test inverted flight
    • Autotune
    • Ground mode flags are tested
  • Want to stop linking AHRS
  • Want a way to not link a library, rather than set a define to not compile something

UTC2327 - vehicle updates

UTC2344 - AP_RangeFinder: allow for more than 327m range by peterbarker · Pull Request #27886 · ArduPilot/ardupilot · GitHub

  • Allow for more than 327m range on rangefinders
    • We should definitely be taking the minimum of the maximums
    • As vendors definitely over-state
    • And raising the minimum makes sense
  • Should we change the parameter names?
    • No-m at the moment
      • Should we add a unit into the name?
    • We’re not going to do that
  • Deprecation warnings are quite nice
  • Merged!

UTC2354 - Ensure all peripherals define HAL_PERIPH_ENABLE_GPS to 1 or 0 by peterbarker · Pull Request #28127 · ArduPilot/ardupilot · GitHub

  • AP_PERIPH_GPS_ENABLED rather than defined(HAL_PERIPH_ENABLE_GPS))
  • One at a a time or all at once?
  • Random MSP patch needs to go away
  • merge after removing MSP thing

UTC0001 - Heli autorotation restructure mode and improve speed controller by MattKear · Pull Request #28209 · ArduPilot/ardupilot · GitHub

  • Heli autorotation restructure mode and improve speed controller
  • Needs to understand the get_last_loop_time_s vs kleeping your own uint32_t counter
  • Matt will need to look

UTC0006 - Support for scripting in flash using littlefs by andyp1per · Pull Request #28724 · ArduPilot/ardupilot · GitHub

  • Scripting support in flash using littlefs
  • Still need to know about the lockup
    • Locking code was revised a bunch
  • Hugely useful feature!
  • Merged!
  • Change the way the custom build server works?
    • –enable and –disable
    • Maybe….
  • Need a blog post

UTC0016 - Tuning indication on OSD(and GCS) by Yury-MonZon · Pull Request #28831 · ArduPilot/ardupilot · GitHub

  • Tuning indication on OSD
  • Merged!

UTC0019 - Do not allow users to set throttle-based notch in Heli by MattKear · Pull Request #28843 · ArduPilot/ardupilot · GitHub

  • Do not allow users to set throttle-based-notch in heli
    • Throttle means collective in heli!
  • Varying head-speed would mean rpm or fft-based filter
  • merged!

UTC0023 - Plane:mode AUTOLAND enhancements by Hwurzburg · Pull Request #28976 · ArduPilot/ardupilot · GitHub

  • Autoland improvements
  • Altitude radius impacts from PH
  • Get it in and get it tested
  • Probably much more intertest in this now it can be used in all modes
  • Dome discussion around prearms vs config errors
  • We have a page for every single error message ArduPilot can produce: Pre-Arm Safety Checks — Copter documentation
    • Might look at extracting

UTC0029 - Rework SPL06 to do background updates compliant with the spec by andyp1per · Pull Request #28983 · ArduPilot/ardupilot · GitHub

  • Background mode for spl06
  • Betafpvf405
  • Need to test on the spa06

UTC0043 - Plane: Remove takeoff recalculation dead code by rubenp02 · Pull Request #29079 · ArduPilot/ardupilot · GitHub

  • Remove takeoff recalculation dead code
  • Georacer’s not sure
  • Heading re-capture is an issue
  • Remove it or fix it so it is used?
  • PH thinks we should potentially leave it in as we might want it back soon?
  • Tridge isn’t absolutely sure that the course isn’t set
  • Implications of getting this wrong is the plane flies away

UTC0057 - Add support for 32 motors, including dodecahexa-octa (two-layers of 8 motors each) by peterbarker · Pull Request #29020 · ArduPilot/ardupilot · GitHub

  • Add support for 32 motors
  • Failing layers at a time…
  • Tricks for not logging channels do suck
  • Do-set-servo
    • Different defaults for 16 and above
    • Just for logging purposes
  • Need to address Andy’s PR but this can go in otherwise
  • PH wants to see a 32-motor example at the conference!

UTC0115 - Fixes for AM32 Passthrough by andyp1per · Pull Request #29056 · ArduPilot/ardupilot · GitHub

  • Fixes for AM32 passthrough
  • Should we have DMA’s the 19200 config protocol
    • Or should we have spun up a high-priority thread and bit-banged it?
  • Some testing to be done in Canberra for this
    • On Nessie

UTC0121 - AP_Soaring: Rate limit the NVF publishers to 4Hz by Ryanf55 · Pull Request #29064 · ArduPilot/ardupilot · GitHub

  • Limit nvf to 4Hz
  • Needs many bugfixes

UTC0124 - AP_Mission: better deal with home being in index 0. by IamPete1 · Pull Request #29071 · ArduPilot/ardupilot · GitHub

  • Tidy up index-0 handling
  • Writing home doesn’t re-trigger terrain things any more
  • Dumping raw storage will still get the home location
  • More consistent when we store home in storage
  • Problems with well-written scripts which are checking for errors
    • One small change to fix that

UTC0134 - Move REQUIRE_POSITION_FOR_ARMING bit to AP_arming by peterbarker · Pull Request #29076 · ArduPilot/ardupilot · GitHub

  • move arming-required bit
  • Some magic around what failsafes you have set?
  • Create an ARMING_POSREQUIRE parameter instead
  • Use ARMING_NEED_POS

UTC0146 - Adjust slope terminology by rubenp02 · Pull Request #29087 · ArduPilot/ardupilot · GitHub

  • Use “alt” rather than “glide” for slopes
  • Naming change
  • Both code and profile names
  • ALT_DELTA_MIN
  • ALTERR_THRESH?
  • ALT_DELTA_MIN
  • ALT_ERROR_THRESH

UTC0158 - close