Servers by jDrones

Custom Imagery in Mission Planner

Hello,

I am trying to get a rectified orthomosic file output from Pix4d into Mission Planner.

I tried using GEOSERVER as suggested by Nicholas Brieger in his 2013 post on DIY Drones, Using your own map data in Mission Planner and I tried Micheal Oborne’s Global Mapper methodology as suggested in the comments.

Both great tutorials! Thanks guys.

I got the imagery into Mission Planner, but the resultant resolution was poor.

So I am looking for ideas about how I can improve either process to increase the resolution considerable or a different approach entirely.

The first image is the image quality from glabal mapper the other image is what I am seeing in Mission Planner.

Thanks for your help.

Dave

both methods should be possible to get a lot better resolution than that.

I tested my globalmapper method with 20cm per pixel data. what zoom level where you exporting to? 21? 22? I assume only 16ish?

Michael,

Thanks for the reply. The GSD of the imagery was around an inch/px. I exported to 20. Doesn’t look like its refreshing tiles as I zoom in.

Any suggestions?

Thanks,

Dave

Hi David,

I found the issue, there was an internal limit set to zoom 17. ive changed it to 22.

please try MP beta.

Michael

this affected both WMS and custom. I have fixed both.

Fantastic! Thanks for the fast action.

Dave

Updated to the beta version. Huge difference. Awesome.

Thanks Michael.

Michael,

Excellent work. Thanks

One of the things I am trying to do is capture the elevation profile of objects in the imagery, so I can fly over them. In the example above, I am trying to capture the height of the tractor trailer and create a waypoint plan around the perimeter of the trailer to fly few feet above it. Without elevation data, the drone will fly a few ft above ground level instead of a few ft above the trailer height.

Not depicted in the image is a road to the north of the trailer on a fairly big hill. When I scroll over the road the elevation readout in Mission Planner increases as I go up the hill, which indicates elevation data is included in the tiles. Do you know why the trailer is appearing as a flat object? Do you have any suggestions?

Thanks,

Dave

elevation data is from srtm, its not part of the tiles at all. and its accuracy is ±20m

Thanks. Still learning about the different types of data. Is there anyway to get elevation data into mission planner?

yes, using geotiff format. just place a geotiff in the srtm directory, and mp will use it.

Michael,

Thanks for working we me on this. I dropped a rectified ortromosiac tif file from Pix4d into the srtm folder. What map source do I select in MP?

Dave

tif containing elevation data? or normal mosaic? the srtm directory is meant for elevation data.

Micheal,

I really appreciate your continued engagement and the video. But I wasn’t able to follow any of it.

I have Global Mapper and Pix4d and I am trying to get custom imagery with survey grade elevation data into Mission Planner. I have the outputs from Pix4d. I just don’t know which ones to use or how to get them into mission planner.

I am willing to pay for a step by step tutorial.

Thanks,

Dave

the video should cover the basics.
i have a few questions

can you load the pix4d elevation data into globalmapper?

all the video is really doing is

  1. load elevation data in globalmapper
  2. check projection is wgs84
  3. export elevation data as 16/32bit geotiff
  4. place geotiff in srtm folder.
  5. test that the data is loading from the geotiff.

since i created the video i added a field by the coords and alt about the datasource. (in flightplanner)
this change will be in MP beta only at the moment though.

Michael,

Thanks for your continued engagement. I really appreciate your expertise and assistance.

So I converted the Pix4d DSM output to a geotiff using Global Mapper, placed it in the SRTM folder and opened Mission Planner.

Before I converted the DSM I ensured it was in WGS 84 and validated the elevation data.

I see the file loaded (picture attached) into Mission Planner, but I still have no elevation data in flight plan. I reviewed your video several more times and think I am doing everything right. But I must be mission something.

Ideas?

Dave

your issue is the projection system. it should be geographic wgs84. the tiff is good, but it definitely is not in wgs84
what system is the 446120.343 and 4244271.201 ?

That did it. Awesome!

Everything works perfectly. The altitude data is perfectly matched with the custom imagery. Fantastic.

Thanks so much for all the help. It’s greatly appreciated.

Now on to the next challenge. We are integrating RTK and would like to change the waypoint radius to something less than 1m, which appears to be the limit. What is required to tighten the waypoint tolerance?

Thanks for everything,

Dave

I seem to be having an issue loading custom geotiff DEM’s. I delete everything in the SRTM folder and copy in a DEM. The DEM is in 4326 and I am using MP V1.3.41 build 1.1.6110.31287. Is there anything about this that is incorrect? I’ve watched Michael’s video from above and don’t see that I’ve doing anything different. However I also cannot figure out how to view the debugging console that he pulled up to show that the Tiff had loaded properly. Any thoughts on how I can go about troubleshooting this? This is a really invaluable feature for what we are doing!

Other thoughts:

Elevation shown is 0m in flight plan screen
To the left of shown elevation is Ocean (??)

I have just been asked the same question and have gone over the instructions.
Michaels video and the quote above seem to be the solution.
A client has the data in a 5m pixel res DEM and wants to use it in Mission Planner.
As I understand it you have to convert your DEM to a geotiff for it to work.

Haven’t verified it yet.

Servers by jDrones