CubeOrange can not receive vision message from T265

I need help. I’m setting up CubeOrange (Rover-4.2.2) and T265. However, I cannot receive the vision_position_estimate_msg and vision_speed_estimate_msg sent by the companion. I tested it with PixRacer, pix32 v5 on the same companion and it worked fine. Only Cube Orange cannot be processed. Unable to see the message in the Mission Planner’s Mavlink Inspector. Any advice would be nice.

[Companion side]
I use this script from GitHub - thien94/vision_to_mavros: A collection of ROS and non-ROS (Python) code that converts data from vision-based system (external localization system like fiducial tags, VIO, SLAM, or depth image) to corresponding mavros topics or MAVLink messages that can be consumed by a flight control stack (with working and tested examples for ArduPilot)..

[FC side]

1 Like

It doesn’t seem to be a physical cable connection issue, I’m very confused …


I can think of two possibilities:

  1. something has gone wrong with the serial port’s flow control. It may help to set BRD_SER1_RTSCTS to 0. This is rarely the issue though.
  2. SERIAL1_OPTION has something set incorrectly. For example “Swap” which is a poorly named option but means the TX and RX pins are swapped
  3. SYSID_THISMAV is different between the autopilots meaning the messages aren’t forwarded to the GCS so they are being sent but you can’t see them.

Thanks for comment!
2 and 3 are negative. I already tried.
I’ll try 1 today.

I also found this discuss in Cubepilot forum.

1 Like

Testing using another serial port on the CubeOrange (e.g. Telem2) might also be a good idea in case the problem is a hardware issue.

1 is negative.
Telem1 and Telem2 are same issue.
USB connection is working perfect… but I’m going to use another FC.

1 Like