Cube yellow cannot find Here 2

Hello, i recently configured hexa cube yellow with firmware 4.0.2. Everything is ok except there is no comunication with external compass and Here 2 gps and internal compass. I tried switching off both of the compasses but still can’t fix it. Any help? Is it firmware problem? I am running ChibiOS as on my other copters with Cube black. Will it be fixed if i try PX4?

1 Like

Set LOG_DISARMED=1 and share a log.

Thank you for your quick reply. I will share it as soon as i reach my drone.

Hello, I set LOG_DISARMED=1 and downloaded the last log file. i tried compass calibration and it stops at 50% - Only one compass working.17 1.1.1980 г. 02-00-00 ч…bin (732 KB)

I think there are problems with the Cube with the F7 processor, i also have problems with the Orange Cube that the external compasses are recognized.
The developers have to take a look at that.

Have you connected here2 on CAN port or serial/I2C? Can you share a screen shot of HW ID tab on Mission planner?

If it’s on CAN it may help to set the BRD_BOOT_DELAY to 5000 (milliseconds). I haven’t seen any confirmation from users that this has helped with Hex CAN compasses so if this does work please tell me. Thanks!

Hello, today i got random error “Check BRD_TYPE: Failed to update IO firmware” without any changes from me from yesterday. I upload the HW_ID screenshot, GPS is connected on I2C

. I tried moving to CAN and setting BRD_BOOT_DELAY to 5000, but still cannot find Here 2. On my initial setup, when i start compass calibration, the external compass starts calibrating up to 30% even when the aircraft is stil and it gets to 50% when i try to calibrate it and freezes. The internal compass doesn’t start at all.

First, Resolve your power source. From the log, you can see low voltage warning of 4.1V. It’s probably your usb cable. Use the cable provided in the Cube Box.

Once that’s solved,
Connect Here2 4-pin CAN cable to CAN1(One in the middle)
Click COMPASS_TYPEMASK and uncheck UAVCAN option.
After this, Share a screenshot of HWID again.

1 Like

I’m undergoing like this case… (at orange, here2, can, ac4.0.2) but no effect ‘brd boot delay 5000’(upto 10000)…

Just tested with Cube Orange and Here2.
Try Setting Compass_typemask=910

Hello, When connecting GPS to CAN with the parameters configured as you suggested, calibration starts with the 2 compasses. I did not finish it, because i was wired with cable, but it looks ok. I hope that fixes it and thank you all for the effort. I am sending HW_ID

Is there a way to fix it with I2C port, because I am using the 30cm GPS cable from ProfiCNC and it is more pins? Also, i have to try Compass_typemask=910 on CAN or I2C?

Hey @rmackay9 @proficnc
Looks like there is some bug in Compass masking. Or probably something else related to UAVCAN compass. The UAVCAN compass initializing is random and unpredictable without changing settings on CubeOrange.

As per my previous reply, the compass was initialized. but without changing setting, on second boot, it just disappeared.
I tested with different Here2 GPS. Same issue. Had 5secs of boot delay on all tests.

Hey @rmackay9
Tried one here2 on Serial/i2c and one on UAVCAN, I2C compass works all the time. But UAVCAN doesn’t work most of the time. You can check the clock below, This happened in the very next boot.

I just went out calibrating compass on CAN. Every time calibration was unsuccessful. Sat Count was all time 0. On I2C i can’t even access GPS. Maybe there will be any fix on next firmware?

Hey @rmackay9 @proficnc
Tested on CubeBlack and it works perfectly!
Checked Bus Monitor on both Orange and black. Here2 is sending data without any issue. Looks like some issue with new H7 processor.

On my Cube Black same configuration works also perfectly. Only on Cube Yellow it doesn’t work.

as in my case
(cube orange, here2 * 2, ac 4.0.3dev)
only checking uavcan at ‘compass_typemask’ , brd_boot_delay = 5000.
power cycling and reboot pixhawk make order confuse ‘compass devid’ like below. sometimes it is not detected
(same hardware setting, just reboot)

compass3 compass4

Yes. Probably something with new yellow and orange cube. @tridge @iampete @rmackay9 any suggestions?

UPDATE: Compasses could not be calibrated. GPS could not find any satellite. At some point 10 mins after power up, the drone armed by itself when RC was off and run out and fell. WTF is happening with Cube Yellow. Today i started every parameter from beginning and checked twice. I have the same crafts with Cube Black and they run good.