Servers by jDrones

Cube stuck on Bootloader flashing a orange light continously

ardupilot
arducopter
pixhawk21

(Arjun Kapoor) #1

I uploaded firmware version ArduCopter 3.5.5, and my cube was working fine till now, it flew few flights very well , now it is getting stuck on the load and orange light keeps flashing, i have erased the full chip,now uploaded the fmuv3_bl onto memory location 0x8000000, and code on after 0x8004000
but still it is stucking on the bootloader with orange light flashing continuously. does anyone faced such issue? i need to solve this soon,thankyou


(R Q Robert) #2

How do you upload the bootloader?


(David ) #3

good day, did you flash the bootloader via jtag?


(Arjun Kapoor) #4

uploaded via jtag using ST programmer. does it matters how we upload?


(Arjun Kapoor) #5

yes! via JTAG, but the cube wasn’t working even before, uploading the boot loader was what i thought will be the solution, but its still stucking in boot flashing orange light, do you think by any chance it is unable to init the Gyro and some other sensors on bootup?


(David ) #6

maybe something got wrong during the flash, just do the full erase chip… and also the sectors, dont touch the mcu levels. Don’t forget that your board have also the failsafe co-processor.
If you are using the nucleo board don’t forget to remove the pins from stlink v2
just format also your sd card and try reinstall the firmware.
Which file did you reflash


(Nathan E) #7

Double-check your setup by isolating the board (unplugging all of the inputs and outputs). If it doesn’t get stuck, then you may have an issue with an external component, not your board.


(Arjun Kapoor) #8

hi i tried erasing full chip and also the sectors after 0x8000000 ,
connected to Qgroundcontrol it says : intiailising APM
then says unable to detect board type, check BRD_TYPE
set it as CUBE/PIIXHAWK it started working ! :smiley: Thanks for the help thou


(Arjun Kapoor) #9

the issue was it wasn’t detecting the board type, i thought it as a bootloader issue, but solved now


(David ) #10

If you are using st link utility just make also a backup up of the bootloader, just connect… don’t change anything… on file you have the option save as file, save it for a future recovery.
just write on a simple bloc notes the procedure.
You are welcome