Cube orange pixhawk2.1 & here3

I’m using cube orange pixhawk 2.1( firmware 4.0.2 plane ), i face the problem on compass calibration always red or not complete what could be the reasons?

Too much magnetic interference. And please update to Arduplane 4.2.1 before continuing.

1 Like

Dear Mr. Amilcalucas

Please help .
I am very beginner .

I am using Missopn Planner ( Multicopter Firmware 4.3.0) with Orange Cube +Here3 GPS .
I have been watching some Youtube video for setting which are saying “Set GPS ID 1 to 9” .

But I could not find GPS ID Setting parameter .

Which parameter shall I fix ?
How shall I do ?

Please help


What is you actual issue you are trying to solve? Why do you want to change “GPS ID” ?
Did you follow the Cube Pilot documentation on setting up the Here3?

Re: Trying to solve : Cube Orange and HERE3 GPS work properly . It is now " No GPS " .

Re: GPS ID : Because of some setting YouTube Video said so .

Re: Cube Pilot documentation on setting up the Here3 : Yes . I think I did it .

Try setting BRD_BOOT_DELAY,5000 to ensure your Here3 always boots up before the flight controller.
Can you get a screenshot of the MissionPlanner mandatory, HW ID screen?

I could not find “BRD_BOOT_DELAY.5000” parameter setting on the Mission Planer.

Thank you so much for your help

It is definitely there, under BRD not BAR

There is not BRD .

One thing = LED light on HERE3 GPS antenna
Manual said “Not lighting up: No firmware detected or firmware corrupted.”

Do I need to install special firmware for HERE3 GPS ?

If there’s no LED the CAN GPS could be plugged in wrong (but you have a CAN compass showing up)

BRD_BOOT_DELAY is a parameter under Config / Full Parameter Tree , set it to 5000

Disconnect power and reconnect after changing that. Then you should have the GPS unit show up under Setup / Optional Hardware / CAN GPS order

1 Like

Thank you so much for your help .

There is difference between your menu of screen picture and mine .

Is there another mode for the mission planner ?

I will try !!!

Thank you so much again !!!

Are you going into Config where all the parameters are?

Also go into Config / Planner
and set Layout “Advanced”

You might want to check you have these other parameters set correctly too (note - there’s another BRD parameter in the list :slight_smile: )


Be sure to “Write Params” when done

1 Like

Bingo !!!

Thank you so so so much !!!

My cube orange now could detect HERE3 GPS !!!

It seems my problem solved .

Thank you so much again !!!