Cube Orange Pixhawk 4 no connection via Usb

Hey Guys,

I tried to connect an new Cube Orange Pixhawk, fresh out of the Box to MIssionplaner.

I got an fresh Windows 10, actually Missionplaner an the current drivers. I followed the instructions for a first setup like here:

But i dont see the Board in the Device Manager. There is no connection, only the orange light is solid on.

I got an ChinaKlon Pixhawk 2.4.8, this one is shown up. But i tried nearly 2 Weeks to get a Firmware on the Board. If i plugged the board via usb on, only the orange LED starts, nothing else.

This is a long shot but it might be quick fix. Try QGroundControl. Even though I have a couple cube Oranges on the go, I can’t for the life of me remember what they come loaded with. The Cube may come pre-loaded with PX4 so it will need to be reflashed to one of the Ardupilot firmwares to show up in Mission Planner. If it’s on PX4 then it will show up in QGC.

1 Like

The board is not recognized in Windows 10, MP and QGroundcontrol

Only the Orange LED is on, if the Board is plugged via USB

Not to belabor the point but from the QGC firmware tab and then connect to USB you don’t get the option to flash?

Look here:

There is no Option for anything

I also the same issue. Did any one solve that problem?