Cube Orange issue

Hi everyone.i got orange cube 3 days ago only.i upload latest copter firmware.i heard tone and popup upload done or is amber leds on.thats sound,cant connect to mp.cube is recognized as proficnc cube 7.even cant upload differeny firmware.message shows No need upload already on the board.any help?

Did you update to the Beta V4.0.0-rc1?

It was daily build from last wednesday i think.since this time is like that.i tried upload beta today but no luck.

If it’s a flashing problem I usually have good luck using QgrounControl. Select the Ardupilot Flight stack, the advanced settings button and Beta from the pulldown menu.

I did it.there is no connection.i can see cube on com port when replug but cant connect to mp and qcs.even i try upload last beta it stay on conecting for while.then come up jus message that its already on the board.dont pass all fleshing proces.

By the way.Orange Led is still on.

You will need to reinstall the drivers. You should see something like this in MP:CubeOrange%20Ports
Take a look at this thread:

I reead that.looks like same problem.i did reinstal them couple times.maybe i missing any part of this topic.i will look ay it later.

No boys,no luck yet.i tried follow this post and still just one laptop running Win7 so i will try it tomorow on win10.

I was able to get Win 7 to connect reliably, but can’t upload firmware. Finally gave up and moved on to a Win 10 machine and it worked perfectly. You may still have to run the clean driver utility, but my experience with Win 10 is that once you have it working your golden. :slight_smile:

1 Like

Ok i tried few mins ago win10.following topic you send me.i was able upload drivers.bootloader clean.i saw 2 comm ports.when i hit connect nothink happend.i tried both ports.what can i do now?

So your showing both MAVLink and CAN ports in device manager ?

All you then need to do is connect via the Mavlink port.

Also advised you ensure your using the beta mission planner as well.

Have you flashed the 4.0 beta ?

Hi.i tried connect via MavLink.nothink happend.i tried upload beta coluple time but is always stock in connecting.after that just came pooup that no need upload.doesnt matter wich firmware is it.first time i upload daily build few days ago via old win7.after that is orange led solid and cant do anythink.even i see 2 comms ports and bootloader detect board.

Can you post a screen shot of the posts shown in mission planner when it’s connected ?

Also have you tried as follows.

Flash to plane 4.0 And see if you can connect then flash back to Copter 4.0 and try again.

As mentioned make sure you have the best of MP installed.

I tried flesh few times different firemware.i am not sure which screenshot you need.i have only this for now i made just from phone.first is from win7 and second win10.

Just one more think.when i hit connect then came massege Cant open comm port.

Hi.i doing it right now.i gonna write here what i doing.maybe i do somethink wrong.
1.Instal mp
2.After instal question:beta update available,wanna instal,YES.instaled,mp rebooted.
3.driver clean from file
4.instal uav drivers
5.connect cube.its orange cube bl or so.
6.update driver to Cube orange SLCAN
7.switch to beta firmware and instal diferent firmwares+downloaded msi.
Even i change drivers to other same result.CONNECTING…after that:no need to upload.already on the board.
its Win7.

If you have a Windows 10 machine available I would use that instead.

I will do that this evening on win10 pc.

@Gucimi - I think that will be the easiest route. I have wasted a lot of time trying to get Win7 to connect or update firmware. Win10 may require running driver clean and reinstalling the drivers, but afterwards I was able to reliably update firmware and connect to the aircraft.