Cube Orange gets "bricked" in Copter >= 4.1

I have 3 Cube Oranges and I have tested them all: right after I upgrade it to Copter 4.1 and 4.1.2, I got this message in MP:

Config Error: Fix problem then reboot - first time to see

The LED did not turn off

When I roll back to <= 4.0.7, everything went well again.
I remember in the past, I tested the 4.1 RC/beta, after that I went back to 4.0.7 and I never updated to the 4.1 official until today.

Hope that someone will help to figure out the issue.
Thanks,
Vu.

I forget to mention, this is the similar message but I have no clue to link to my problem because of 2 different hardware "Config error - fix and reboot" on Matek F405 wing (new board)

Did you tried a fresh install instead of update? Just install plane then install copter again.

Sorry, I may not get you at the point of “fresh install”
Everything I did is installing from MP:

  • For 4.1.2 → click the symbol of the Quad
  • For previous: download from firmware sites and load it here

Fresh install means not update.
First install Plane or Rover to the flight controller. This will erase everything.
Then install copter again. That will be a “fresh” install.

Thanks for making it clear. I have tried the Rover 4.1.2 → Power off → Power on → Plane 4.1.4 → Power off → Power on → Copter 4.1.2 → Power off → Power on

The same thing for 3 cases:

This is really weird.

Do you have any external components connected ?

No it is just Cube only, no compass, GPS… connecting

did you inserted an so card? on the picture you sent there is no card.
Also it looks like a custom carrier board. Do you have an original carrier board to test ?

I have tested with the version of inserted SD Card.

Yeah, it is a nice catch, this is a custom carrier. I will try to grab the original one to do the test. Hopefully it is about the hardware issue. However I also want to emphasize that Copter <= 4.0.7 is working well in this board. It is highly appreciated if you can help to point out some differences between 2 versions (copter 4.0.7 and later) so that it leads to this situation.

based on the error messages i think it will be something with the SPI bus. There were many changes in the code, but since all three vehicle type has the same error, the issue should be in a driver or in a HAL/Chibios

Okay, I am gonna test with the Hex original Carrier and keep you posted.
Thanks for the help so far.

Does the message CHECK_IMU1_PRESENT appear on 4.07? That IMU is 1 of 2 vibration isolated IMUs connected via flex connector. It is possible that connector has come loose.

Did you by chance remove the cube from the carrier board before these issues?

If that message persists in both 4.1 & 4.07, you should post about in the CubePilot forums as they can best help diagnose and if necessary help you RMA it with your distributor.

Okay, I have checked the those Cube(s) with original carrier board and they works well with Copter >=4.1
Thanks @hendjosh and @Eosbandi for investigating this with me.
I am suspecting that my home-brew carrier does not have VDD in for Servo VBUS monitoring pin so at the >= 4.1 version, there is a function that checks the validity of this voltage. This should not be a big problem for my application because I am not going to use this Autopilot for flying. Will dive more on this when I have time.

Regards,
Vu.

It turned out the power VALID pins in the Cube must be set appropriately.

Hi everyone. I have a fresh Pixhawk Orange Cube. I have tested it and it works fine. Now I tried to upload Copter 4.1.2 and it doesn’t work. In Install Firmware Page on status Com Port 8 detected is shown but then firmware didn’t load.

I tried uploading Copter 4.1.5 and it worked. Then I tried uploading Copter 4.1.2 but the same issue occured.

Can you please help me out with this issue?

Yes. Keep the 4.1.5 version. It is better.

:grinning:

Ok. I’ll do that. Thanks.