Cube Orange connection with T Motors ESC

Hi everyone, i have problems with connecting T-Motors Flame 200A HV ESC with Cube Orange autopilot. The ESCs just constantly beeps and trying to find connection. I tried to connect with ALPHA 60A HV also T-motors ESC and it connects successfully. Everything is fine with those smaller capacity ESC, the drone flies well. I dont know if its up to the frequency of the ESC because ALPHA 60A HV works on 500hz and FLAME 200A HV works on 621hz. If somebody can help me it would be much appreciated. Thanks!

Are the ESCs using normal analogue PPM servo signal or DSHOT-600, DSHOT-1200, etc etc?

If analogue PPM, check that they work on their own by connecting up a servo tester and see if the motor spins (take off the props first!!!).

Hello, thank you for an answer. They are using normal signal, i tried also the rest signals u mentioned but its the same, the ESCs just constantly beeping and searching for the connection. I will put two links here so you can see what I mean. First will be with Pixhawk 4 autopilot,and second will be with Cube Orange autopilot. You will see that everything is fine with Pixhawk 4, all the ESC connects successfully. But with Cube Orange they don’t connect.

Pixhawk 4 video demonstration:

https://drive.google.com/file/d/1WHEjD4MKzO_JRVKmxPTVD5x_Iz-9cWtP/view?usp=sharing

Cube Orange video demonstration:

https://drive.google.com/file/d/1NXgvB5qCvczyTvDxvxP-DS4OLf99oYz6/view?usp=sharing

Hope to hear from you soon.

Please check BRD_SAFETY_ ENABLE parameter wheather it’s set 1 …if yes try to press the safety button

There is no safety sw on cube orange gps(here 3)

The Cube Orange comes with a safety switch, and most firmware versions default to using it. You must set the parameter appropriately.

Yes @Yuri_Rage said correct… default firmware safety enable only…if you disable it your esc will get PWM signal and works normally.

BRD_SAFETY_ENABLE IS SET TO 0

I dont know if you remember but if u see my first message you will see that everything is working fine with ALPHA 60A HV ESCs also from T motors, so i dont know why its not working with FLAME 200A HV

I am facing same problem, with T-motor flame 200A ESC.
I tried to use only ground and signal wire of ESC but it didn’t work using pixhawk cube orange & black. same result if I try to provide signal through futaba receiver’s channel 3.
Then I hooked up signal(black), power (red) and Ground (black) wires into the esc connector and connected it to the receiver’s channel 3 the beeping stopped and motor was spinning but if I try to do the same via pixhawk, it doesn’t work.
If you found the answer to the problem then please enlighten me.