Cube Orange cannot detect Here2 Compass on UAVCAN

This is a new topic created to discuss issues with AP Copter-4.0.3 (and higher) being unable to receiver compass and/or GPS data from the Here2. This topic is split from this earlier discussion.

Please report issues below ideally with log files and any other information you may have. To keep the investigation focussed please keep reports focused on CubeOrange and Here2 connection issues.

1 Like

Hey @rmackay9
I just created a new topic. Didn’t notice you created one here. Sorry!

cube orange
here2 * 2 (using uavcan)
ac 4.0.3 rc1

I attached ‘disarmed log’
it rebooted at same setting.
at first booting compass not detected
if click ‘pixhawk reboot’, second boot have compass detected

Cube Yellow
Here 2 (Using I2C)
ac 4.0.2 Official

First time compass recognised and calibrated (on CAN it is only recognised), but this happened only once. When starting calibration, internal compass gets to 15% at the beginning. Then, after 4-5 unsuccessful attempts, calibration was finished. After restart, we could not calibrate compass again.
IMPORTANT! GPS cannot find any satellite at all. We tried different environments and configurations.

I noticed further that battery monitor is not working properly (when placing Cube Black on the same machine it works) and i am attaching screenshots below. It gets from 100% to 0% and back randomly in 0.5 secs interval.

I attach a bin file here:
37 1.1.1980 г. 02-00-00 ч…bin (979.7 KB)

Running a pixhawk V1 and Zubax GNSS I lost connection with the compass upon upgrading to 4.0.3 from 3.6.7. Any updates ?

I am on 4.0.3 and I have it working just fine with Cube Orange and Here2.

Change your brd_boot_delay to 7000 and that should work. I originally had it at 5000 which is what I used with my CUAV Neo V2 Pro can gps. However it seems the Here2 needs a little more time to boot up.

I have 100% success rate at 7000.

Was this on CAN? I have this working with a CUAV V5+ FC on 4.0.3 with the Zubax GPS/Compass. set the BRD_Boot_delay to 5000 and you should be good

Update: I changed boot delay to 5000 and now it works on my pixhawk 1. I don’t know why on 3.6.7 it wasn’t needed…
Thank you @smartdave :slight_smile:


A bit unrelated, what was your experience with the CUAV Neo v2 CAN?
Did you have any issues? Why are you going back to Here2 now?

Thank you for your insight.

Love the CUAV can GPS. It have the newer rm3100 compass in it. I have 2 of them.

I bought the Here2 just as a test, not to actually use.

I also bought a Zubax CAN GPS.

I am looking to sell the Zubax and replace it with a Neo V2 CAN.

Infact I just ordered two more CAN NEOs to replace my I2C NEOs

Thank you Dave, have a good evening.

1 Like

Hi All,

Were are seeing this problem on a number of copters. We have several dual GPS aircraft with one Serial+i2c connected Here2 and one UAVCAN connected Here2. The serial+i2c units work without problems, but the compass on the UAVCAN units will frequently fail to be detected or send data. Going through flight logs we can see the UAVCAN compass has a roughly ~50% chance of booting and being detected.

We use a boot delay of 5000 as a standard parameter. However, this only seems to reduce the issue. We have tried adjusting that parameter between 3000 and 7000ms with little improvement. Is there anyway we can help troubleshoot the issue or any additional steps we can try to reduce it?