Servers by jDrones

Cuav v5 nano calibration issue

Hello to everyone. i am new to this forum. I don’t know the rules exactly, I apologize in advance. but i have a big problem. I created a new quadcopter but I couldn’t calibrate the escs. can you help me?

esc: fvt little bee spring 30A
Motors: emax rs2306
boarding pass: cuav v5 nano

First of all, I connected the escs to omnibus f4 card with the blheli suite and made the minimum and maximum throttle settings. I adjusted the motor directions. Then I connected the escs to the receiver one by one and did a manual calibration. Then I connected the escs to the cuav card and made the connection to the mission planner. I installed version 4.07. I calibrated all sensors and remote. Finally, I selected and saved oneshot125 in esc calibration. Then I cut all the power and brought the throttle to the maximum from the remote control and connected the power. After the melody sounds, I disconnected the power and connected it again. After the beeps came, I turned the gas down to minimum. melody and beeps sounded. The last time I gave light gas, the motors worked perfectly. but when I cut off the power, reconnected and arming, the motors lost their calibration and their speed changed. so one motor was 1300 while the other was 1150. I tried all protocols (oneshot, oneshot125, dshot150, dshot300, dshot600) and the result did not change in any of them. When you cut off the power after the calibration, the calibration is broken. what do you think i can do? (I contacted cuav engineers with teamviwer. They also looked at all the settings. They also made a few adjustments. They said ok no problem, you can fly now. Today, as soon as I put the propellers on and arm, the quad crashed into the air like an injured pigeon, and all 4 propellers were broken. By the way, I’m sure the propellers are installed correctly. The motor directions are also correct.)

Is the motor order correct? Tested and confirmed with Mission Planners Motor Test (as I suggested in your duplicate cross post).

Your process is crooked.

You have to do an automatic esc calibration.

Go to Mission planner “Setup, ESC calibration” and follow the instruction.

Do not forget to set PWM Min and Max as on the screen before doing the calibration.

If you need to use DShot, there are a lot of steps to follow before:

https://ardupilot.org/copter/docs/common-brushless-escs.html#pwm-oneshot-and-dshot-protocol-escs

thanks Dave. I hadn’t thought about the engine lineup. I approached with betaflight logic. Fortunately, after your message, I noticed the situation and fixed it. I did a test flight today. it took off when it gassed. but it was shaking a lot. I landed hard. The average wind speed is 28km/h. I also tried running it in auto mode. Even though I set the default(initial), takeoff and all waypoint heights to 3 meters, it went up at least 20 meters. If I let it go it would go to space :frowning: I immediately came out of auto mode and landed manually. Could it be due to the pid values? or wind speed? I don’t understand why.
by the way i used dshot600. Motor’s min-max 1000-2000 frame:250mm (looks like qav250)

Chances are your PID’s and filters are all wrong for this craft if it’s a 250 size. Arducopter defaults won’t work and you have skipped some steps before even doing the 1st flight…
1st connect to Mission Planner and hit Alt>A for the initial tuning parameters plug-in. Input the requested info and then make those changes. This will likely make it flyable.
Then you need to configure the Dynamic Notch Filter.
Then an Auto Tune would be next.
Some reference info:
Initial Tuning
Dynamic Notch Filter
Auto Tune

Hello again Dave. Thanks for your help. I’m new to ardupilot. I stepped on the gas too much on one of today’s flights. (I tried it on the carpet field.) The drone got caught in the upper nets and stayed there :smiley: then the wind dropped it. unfortunately it fell on the gps and the bottom of the gps cracked. Gave gyro calibration error when plugged into mission planner. When I made the calibration and tested it in the open air this time, the 3 meter-adjusted drone started to rise constantly and I intervened manually and lowered it to the ground. I am using cuav neo 3 pro. I am using gps compass. I will try the settings you suggested in the top entry tomorrow. So, does the drone always rise like this in these settings?

It depends on the Flight Mode you are in and whether the Hover throttle has been learned. Or it could be high vibrations, Baro noise, etc. You really shouldn’t even be flying it. The Initial Tuning Parameters are to be changed pre-maiden flight…

understood. I mean, I survived without a serious accident. The cost was 1 set of propellers and a slight crack in the gps. I’ll try the settings you suggested tomorrow. Finally, after arming the drone, I push the switch that I assigned to auto mode, but it does not go into auto mode. If I push the switch after manual ventilation, it goes auto mode. where can i do this setting?

Hello again Dave. I made the settings you said. no more vibration. I assigned auto mode to the 7. switch. I put waypoints at intervals of 3 meters. I arm the drone and immediately switch to auto mode and the drone is thrown without going to the waypoints. map is up to date. I set the takeoff height to 3 meters. waypoints are also 3 meters. I set the speed to 1 m/h. but it doesn’t do the tasks in auto mode.

I don’t know why you are trying to fly an auto mission before completing all tuning steps.

I don’t know what you are describing here. Post a link to a .bin flight log.

https://drive.google.com/drive/folders/1GSl9KVA1E3W_16wYITPJiyaojzS2scXR?usp=sharing

Hi Dave, I added the log and bin file links. could you take a look?

I don’t know what you are describing. The log shows shows it went to some waypoints.

BTW-It doesn’t do any good to enable the Dynamic Notch Filter w/o configuring it. Those are the flight you should be making.

Also, suggest you go here and put a like on the guys post for Bdshot on CUAV V5 nano. You can take advantage of this.


Do I just adjust the dynamic notch settings under the title in the picture?

otherwise there are many settings on that page and I didn’t know which ones to do.

Click the link in the post above. Instructions for configuring it are there.

Servers by jDrones