CUAV Pixhack V3 - Board version px4v2 or px4v3?


I have a Pixhack V3 board. When I try to upgrade firmware in mission planner it says: detected a px4v2. I thought it is based on FMU3. So should I manually upgrade the firmware to ArduCopter-v3.px4 or leave it as px4v2 as detected?

Best regards


fmu v3. Your board may have an older bootloader (not a big issue, but updating is an option).
You could use a ChibiOS firmware too (

Hello James

How can I update the bootliader?

Thanks for your answer

Best regards

Good day, if you want update the bootloader you must use a jtag programmer


If using a Chibios version, and inside Mission Planner if you do a CTRL+F there’s an option to flash the new bootloader.

There’s no need for that.

i got your point but with the option used from mission planner you can risk to brick the board, using jtag programmer you can also do the backup of your previous bootloader… just in case of corruption

Hello Luis

Thanks very much for your input. I could update the bootloader as you described. It shows now fmuv3 and I can also download new firmware via Mission Planner.

Best regards

Hello, it is fmu v3, but unfortunately your board bootloader uses the old one, you can manually upgrade the bootloader. If you have any questions, please contact cuav. thank you for your support.

Good to know it worked as intended. That option is very useful although the jtag connection would be the “safest”

but not many people have the required tools to use the jtag solution (I don’t).

Happy flying

There is a much better way: Pixhawk Bootloader Update

You flash with the DEV build of the PX4 flight stack, set the Sys_BL_UPDATE parameter to ENABLED, and then power cycle the Pixhawk. From here you can flash the latest ArduPilot firmware. When the board is detected you will see FMU V3. I have done this to 2 Pixhawk 2.4.8s.

Be advised that this process will wipe all of you settings, so make a backup…

That is what I tried first and that did not work. Mission Planner did not recognise any more the pixhack 3 when I tried to update the firmware.

The issue here is to flash the ArduPilot brand new and shinning bootloader which is NOT the same as PX4

No, the issue here is you use the DEV build of the PX4 Stack to flash the FMU V3 boot loader and when you flash the board with ArudCopter the board is detected as an FMU V3.

I have done this on 2 Pixhawk 2.4.8 flight controllers.

Just to get things straight.

There is hardware called generally as PixHawk. The original were by 3DR and there are several variants, some built by anonymous manufacturers and some by reliable manufacturers. From all of these there were some where the MCU had a bug, which prevents using the entire flash of 2MB. The PixHack v3 is a good example of a ArduPilot partner that uses the non bugged MCU’s (to my best knowledge).

Then we have firmware running on these boards, which can generally be either ArduPilot or PX4.

As a easy way to easily distinguish between the bugged boards and the non bugged boards, these are referred as FMUv2, for the boards where the MCU has the 1MB bug, and FMUv3 which can use the entire 2MB flash.

Until recently there was no difference on ArduPilot (running on Nuttx) between these, but while adding new features, ArduPilot drops some features on the FMUv2 that would make the firmware exceed the 1MB boundary.

With the move of ArduPilot to a new OS (Chibios) we recovered some flash space, but the difference between FMUv2 and FMUv3 is kept.

Then we have bootloaders. Historically both ArduPilot and PX4 shared some common elements, including the bootloader, and the base OS (Nuttx).

Now, that the move to Chibios is complete, ArduPilot also developed a new bootloader, specific to ArduPilot, and the GCS’s are being updated to recognise what the new bootloader reports to the system, which will make life much easier when choosing current and future ArduPilot versions, so IMHO it is a very good idea to move to the ArduPilot bootloader.

Is there are possibility to see whether the Pixhawk has a buggy MCU?

Not at the moment, but the tool is scheduled to have a way to report the affected boards, very very soon.

edit: here it is: - should go live on master soonish

In your PixHack v3 shouldn’t be a problem. I’m almost certain it is a FMUv3.