CRT PreArm: Roll (RC1) is not neutral in Mission Planner

Anybody help me on this please ? CRT PreArm: Roll (RC1) is not neutral in Mission Planner
The same fault appears for both Pitch and Roll.
Everything looks normal on my RC, unless I’m missing something.
I’ve tried re calibrating the radio on Mission Planner but with no change.

Check RC1 and RC2 trim, and deadzone. Actual values must be withing trim±deadzone

Sorry for the delay and thank you for the reply,
I am trying to setup a Pixhawk Cube Orange (latest firmware) with Arducopter. In Mission Planner (latest). The values for RC1 show MAX 2005 and MIN 982 values with the deadzone value of 20.

I have been taking my time and adding the correct settings for the Here2 gps.
I have also added a Yaapu script to my Jumper T16 (latest OpenTx firmware).
During this time I was able to arm it without any faults, except for GPS glitches as I was setting it up indoors then after a reboot of the Cube refused to arm throwing up the "ROLL RC1 is not neutral and PITCH RC1 is not neutral.
Is it something to do with the values ?

So he said rc value must be in range of rc trim ± rc deadband, nothing to do with min and max value.
Check the live pitch and roll rc in when you are trying to arm, then compare with your parameters for trim and deadband.

I’m an old boy (retired) trying to get my head round this.
The Radio shows 1502us when channel 1 Roll is at mid point.
The Radio shows 1500us when channel 2 Tilt is at mid point.
While Mission Planner deadband is set at 20. Am I missing something ?

and what are the RC1_TRIM and RC2_TRIM values ?

RC_1 TRIM 1494 pwm, RC_2 TRIM 1494 pwm

Can you enable LOG_DISARMED and try arming then send the log ?

It took a while to work how to do it.
I hope this is the correct file.
Here is a link to it https://drive.google.com/file/d/1yt5ZhRX9cOGezTPMSt1Oo1fslHRZy8CW/view?usp=sharing
Thank you for looking.

OK, you should arm with throttle down and yaw(rudder)left. RC1 (pitch) and RC2 (roll) stays center.
You tried to arm with both sticks. This is why got error messages.

2 Likes

Andras your a star. Thank you so much.
In the past I have always believed the way to arm Pixhawks and Pixhacks/clones was to put both sticks in bottom opposite corners.
As always I was wrong again.
Big thank you to Andras to those who spent the time to answer my post. :grinning:

Thanks Andreas, got the same Problem today!!!

1 Like

Hi Stefan_Menne, Deadtillten
I see that you had the same problem as me if you could help me with how you solved it … I read this post but I didn’t get to solve my problem and so now I’ll explain:
This morning I go to the airfield and the only change made was the addition of the fw from 4.7 to 4.1. I was unable to fly as the above written “PreArm: pitch (RC2) is not neutral” appeared on the mission planner. So I did all the radio calibration again and I checked in the Full Parameter List that the Max / Min / Trim values ​​corresponded to those of the radio calibration … so it was
rc1_Max 1935 rc2_Max 1935
rc1_Min 1095 rc2_Min 1095
rc1_trim 1515 rc2_Trim 1515
rc_1DZ 20 rc2_DZ 20

rc3_Max 1935 rc4_Max 1935
rc3_Min 1095 rc4_Min 1095
rc3_trim 1515 rc4_Trim 1515
rc3_DZ 30 rc4_DZ 20

And this last week I was flying with the fw 4.7. it never happened.
I ask for help on how to fix this.
Thanks

Latest news … I’m at home and I’m checking everything again … trying to arm as always I have now the message “PreArm: Roll (RC1) is not neutral” also appears in Mission Plannere I currently have these two messages on the Mission Planner HUD:

  1. PreArm: Roll (RC1) is not neutral
  2. PreArm: Pitch (RC2) is not neutral
    I repeat … until last week that I went with the fw 4.7 I never had these messages.

Enable prearm logging (LOG_DISARMED = 1, reboot) and try arm then reboot and disable prearm logging again, send in the logfile for check.

Thank you for your interest in this problem of mine.
I am sending you the bin file … I followed the procedure that you indicated to me and I hope it was successful in generating the bin file that I sent you.
Thanks

Check your remote settings. You try to arm with RC channel 2 and 4 which does not make sense. Perhaps your controlles is not in mode2, and you forget to change the channel mappings.

Thanks for reply.
Since I fly drones I have used this futaba 14 sg radio in mode 1 … and I have always armed the drone with the left elevator stick bringing it down and all the way to the right … and keeping the throttle stick to 0 … all at the bottom …
While to disarm the drone I always carry the elevator stick in the lower left.
And this has always been done without having any error on the part of Mission Planner (“PreArm: Roll (RC1) is not neutral” “PreArm: pitch (RC2) is not neutral”) … and this up to version 4.7. … since I switched to 4.1 instead, those messages come out on the hud …
that as indicated by someone on this forum I deactivated the RC Channels control in Arming_Check … so these errors do not appear on the Hud.!


Wow. I randomly found this to be the solution after upgrading to copter 4.1. before, it always worked with both sticks down and toward the center of the controller.

I need help please. This is my first build and a total noob to drone building. I get this error when trying to arm “prearm pitch (rc2) is not neutral”