Creating a new post to discuss my last crash

I created a video containing the tracking and vibration information. Looking at vibration information it wasn’t bad, if I understand it correctly. Y axis hit the bottom red line a tiny bit but other than that it seems to be fine. I have rubber between the motor mounts to reduce vibration transferred to the body. I also have the rubber mounts that came with the Pixhawk under the Pixhawk so there is double vibration dampening between the Pixhawk and the motors.

This shows the flight up to the crash point. I was lucky that nobody was injured. The drone hit a stainless steel structure attached to a ute/pickup truck/bakkie. I believe I had the drone in AltHold most of the time

This is the whole directory with all the logs. The flight only starts at 90% on the telemetry log because I had to calibrate again for some reason.

The tune on this craft is terrible. When there is a large difference between Pitch and Roll PID’s usually something is wrong.

The vibration levels are too high. It’s also underpowered/overweight. Soft mounting the motors is generally not a good idea.

Yes, you are lucky no one was injured.

Can you please tell me what shows that it is underpowered? I thought if I could hover at ±50% throttle I am fine. It only draws about 5.5A. These are 260KV motors. I was using the 4S battery for testing and because my 6S was flat from before when I was running Autotune.

When I had the 530KV motors and these props it shot up at 10% throttle.

I thought if the EKF status is below the bottom red line I am ok.

Take a look at the RCOU logs, typically the ESC operate between ~1100us and ~1900us. In your case the average/mean values are fairly high (motors C9 and C10) and in some cases it clips (maxed out). This is normally very bad and means the autopilot can not properly control the drone anymore.

Also notice that there seems to be two groups, motors C9, C10 and C11, C12 which has a constant offset between them. This shows that either the wind was strong in one direction or that you have a balance or other mechanical issue. Maybe if this issue is resolved the thrust would be more equally distributed and bring the mean value down.

I would avoid motor dumps and use this support. In addition to balancing the propellers. Furthermore, I would only test in stabilize and hovering

Using a 4S battery in a copter tuned for 6S is a bad idea.
And you ask why it is underpowered ???

I thought tuning is for the body. I didn’t think lowering voltage would matter because the body is still the same. Seems I was wrong. So if I tune for 6S I need to stay at 6S or tune again if I go to 4S it seems.

Can you please show a graph that looks good?

The wind was about 15km/h and I thought a gust took the drone. I don’t know why it changed direction and just went for it. I did try to get it to lower, but it just kept on going

Here is an example of a better looking graph (from an X8):

The values are much lower, leaving plenty of room for the motors to react. The traces are also fairly close indicating that in general the balance is okay.

Because the tuning is so bad. 4S or 6S wouldn’t make a difference in this regard:

There is very little right with this craft.

Thank you. I am busy rebuilding the drone. I will do some tests this week to see if I can get these values better and I will show what I have done and the results. Maybe you guys will be able to show me what I am doing wrong then.

I rebuilt the drone and I added anti-vibration dampeners on the “table” where the Pixhawk is attached to.

Video showing calibration of motor/compass

Close up photo of laptop screen showing compass/motor calibration

I will attach logs a little later. I have been trying to run auto tune the whole day but the drone refuses now.

I tried from Mission Planner, setting a flight mode, setting a channel on my control and activating it. It says it is in auto tune, it just doesn’t do anything.

I set the pids to 6 to start with. I found documentation suggesting that.

Here is a video of it in auto tune doing nothing. I also show the vibration graphs and ekf status

strange… I typically had this when my sticks were not completely centered (maybe by accident added some trim or did not calibrate the radio properly).
Looks like you have a Failsafe condition (“Bad Battery”) wonder if this could be preventing the Autotune to start…

I always found that the default gains is a good starting point.

It was showing bad battery because it was at the end. I was down to 22V I think.

I double checked and my controller was set to 0 for trim of all the sticks.

This is the log of the final flight where it just hovered around
Final flight of 23 09 2021

maybe it wont start autotune until battery is sufficiently charged. like with phone updates…

Looks like your throttle (yellow trace below) is still a bit over mid stick:

If you enable the messages in the log viewer is keeps saying “AUTOTUNE pilot overrides active”

Yep I agree, but I started each session with a full charge. I kept on trying to go into Autotune mode. I had two sessions today and started both with a full battery.

Here is a log when I started the second session

You will see I tried to enable auto tune over and over using every method I could think of, mission planner, mode select, channel select

So should I do an alt hold then drop the throttle lower and then enable auto tune?

I think it’s worth a try, but just slightly lower so that it is in mid position and the drone still maintains it’s altitude.