Servers by jDrones

Crashing during RTL Mode

Drone Newbie here. Trying to parse through my telemetry .bin file, but I am not sure what I am looking at.

My drone is using the pixhawk mini 4.0 with arducopter V4.0.5.

Link to .bin: https://drive.google.com/file/d/1JQ4VSXN0lTpahGvHZ2TpxHzvvmwJl5m-/view?usp=sharing

At the moment, I can fly the drone in loiter and stabilize mode, but when I attempt to use the RTL mode, it gives a FAILSAFE_EKFINAV-1 error falls to the ground. Any help pointing me in the correct direction is much appreciated. Interestingly, the altitude goes into the negatives when this crash happens:

Hi, I just had time to view the message. It seemed like you activated Rtl while you were having GPS glitch. And that’s likely the reason.
I do not know why you had GPS glitch yet.
Could you send a photo of your drone and we could see where your GPS is located? Also some insight on the area that you fly.


I shifted the power distribution board off of the Pixhawk mini 4, thinking that might be the issue. The data you have is with the board on top.

Location is in between two 3 story apartment buildings. Probably around 100 ft between. No power lines, but there is a large transformer in the area.

do another test flight. and dont activate rtl while having gps glitch and let us know the results

I could not get the drone to arm Pre-arm inconsistent compasses. I calibrated several times. I disabled the Pixhawk compass and could get it to arm. It flew in loiter mode ok. But dropped out of the sky twice at about 15 ft. Here are the logs.

https://drive.google.com/file/d/1SdfCz-G31dZEdPiXnmaGAvGRXtkfMkYB/view?usp=sharing

https://drive.google.com/file/d/1MC-wLCrOLlfPgQCSvSNAip7tjJS93fO4/view?usp=sharing

Hello John!

First of all, you have to configurate your drone properly, I have seen that you are with the default parameters, so you must follow this guide https://ardupilot.org/copter/docs/tuning-process-instructions.html or press ALT+A in Mission Planner and follow the steps. You haven’t got a power module which tells you the voltage and current of the battery, and for me, that is mandatory.

The PWM of your motors is not equal while hovering, so you probably have your motors tilted.

You have problem with vibes, as soon as your motors increase rpm, you have a lot of vibes. Check your motors and propellers, maybe you have to balance them.

And I think that is the problem of your negative altitude, with such high vibes, the IMU cannot estimate the altitude properly. And of course neither the roll and pitch.

The second compass is being interfered by power cables close to your Pixhawk, since it depends on your throttle, so try to move them away. But your first compass is good.

So finally I think that you crashed mainly for the high vibes. After you follow the guide and you solve all the problems, make another flight only hovering in AltHold about 2 or 3 minutes and post that log.

Thanks for the feedback. Quick question the “power management board that I have services the purpose of a power module as well as a power distribution board” per the manual. Do I have some not set right? When I try to do Alt A it pulls up a note BATTERY VOLTAGE MONITORING IS SET AND WORKING

My number motor was acting up so I manually calibrated all the ESCs again. Could that be what was causing the

In the logs there are no information about voltage or current of the battery.

Do you see the voltage and current on the main HUD in Mission Planner?

Servers by jDrones