Crashed Tarot 680 Pro Pixhawk 2.4.7

Today again my hexacopter crashed that too from height

Flight Controller: PIXHAWK PX4 2.4.7
Firmware version Copter 4.0.5
Transmitter: “FrSky Taranis Q X7 ACCESS 2.4GHz 24CH Mode2 Transmitter with R9M 2019”
ESC: Hobbywing XRotor 40A-OPTO ESC
Motors: Tarot 4108 High Power Brushless Motor (380kv)
Frame:Tarot 680Pro


Can anybody have look at log and help me what was wrong.

Did you follow the “ArduCopter tuning process instructions”?
Just google for it.

I did autotuning and inthat itself it crashed.

Hello! What I can see in the logs is that your drone is very poorly tuned, you are with the defaults PID and at some point the drone became unstable. Have you follow all the tuning instructions?

Do i do manual tuning? auto tune once crashed ? any helpful link/video

The tuning instructions mentioned by @amilcarlucas note that the copter needs to have a reasonably good tune before you attempt the autotune. Thus you’ll need to google the instructions and do all of the steps mentioned in those instructions before you can use autotune.

Great, that will be good. Let me do that. Thanks

The instructions are here:
In my experience they need to be read quite carefully.

Tons of thanks, will follow it carefully.

Also, it looks like you haven’t done ESC calibration. That and the other calibrations (accel, gyro, etc) can make the drone very unstable if it hasn’t been done, and needs to be done before tuning.

I did all calibrations successfully.

1 Like

Hello All, i did reset all parameters to its factory setting, calibrated esc,radio,compass i mean did all.
Then tried to test it and it did crash again. Sharing syslog, Can expert help me to analyze cause of crash?

From what I can see in the logs, you haven’t follow the guide: so your copter is not well configurated.
You have the same problem again, your drone become unstable at certain point.

And you have a 6S battery, where the minimum voltage is about 20.4V, and you started to fly with 19.3V… so it is normal that your drone crashed.

  1. Sorry forget to mention , one of lipo cell is dead so I made it 5s.
    Yes i followed everything mentioned on above page, that could not solve it,thats why I recalibrated all after resetting all params.
  3. What does below messages shows, I am searching for it, but if anyone know it please reply

You must follow the guide and configure all params, it doesn’t matter that in the past didn’t solve your problem. Also you can press ALT+A in Mission Planner and follow the steps.

About your battery, when the copter started to wobble, the battery “followed” the movements with a difference of about 2V and that is a sympton that something is wrong, maybe your cells cannot supply all the necessary current or you have bad solders that increase the total resistance.

About the EKF errors I don’t think that those caused your crash, because it was cleared one second later and your drone flew after that.

Thanks all, finally I could auto-tune my Tarot 680 pro.
Surprisingly, auto tune did not change PID values, I mean values before auto tune remains same.

Also I changed location of my GPS module

The autotune did not work, or you did not save the PIDs values in the end of the autotune.
You need to do it again.

Take off and fly in Loiter to ensure everything is working OK, switch to Autotune mode.
Once the twitching is finished DO NOT switch to any other mode, just guide the aircraft back to land and disarm.
Wait a few seconds, switch to another mode such as AltHold or Loiter and test fly.

How to save PIDs values in the end of the autotune? Please help