Crashed mid flight in PosHold (just dropped)

Just crashed in mid flight.
All the way to the bitter end, copter was behaving great.
I was trying to lower it a bit, however it seemed like it lost control - though I pushed throttle to max, it didn’t react and all I was able to do is see it crashing to the parking lot. Seems like I got lucky, only front left arm total loss.

Any way, I would appreciate if someone can help me figure this thing out, since I’m no good at reading the log.

frame: X 680mm
fc: Holybro Pixhawk 4 - latest fw.

bin log:

text log:

Any help would be much appreciated.


The usual symptom of excessive Z vibes is what you describe.
So looking at the ZVibes, although not excessive they are up there, and the fact they are causing clipping is an alarm bell.

Combine that with the overpowered nature of the copter, and the fact you gunned the throttle, the craft was just trying to stabilise itself through the vibrations.
You then responded to the sudden climb by cutting the throttle.

The quad seems heavy on RC2.
Is it balanced?
Was it windy?
It looks like you lost motor 2 as the output goes to max.
When you tried to recover it looks like motor 1 is trying to make up for motor 2.

You haven’t given any details of the build.
What size props?
Battery voltage?
Your power module doesn’t look calibrated as @dkemxr notes.

So it would seem you destabilised the copter by cutting the throttle and it couldn’t recover.
Lost sync?

Take a look at Vcc right after descent starts. It’s ~4V at the crash. It doesn’t look like your power module is calibrated either.

hi all, @mboland @dkemxr thank you for your observations, much appreciated.

Quad is Iron Man 650 / customized to 680
AUW 2100g
Battery 6s 52000
Motors 400kv
props 17"
Note: the quad was designed to use 16000mah with AUW of 3300g. the 5200 battery is just a temporary one.

The only issue I didn’t understand :frowning: is the clipping - I can see the straight lines but didn’t understand what it means. I do understand the Z vibes and would fix it.

I also understand from your analysis that the craft was not balanced and I think it is due to the length of the arms which are bit longer than the original design and I think that the flexibility of the arms became an issue.

I also think that I had an issue with my PM calibration. I did measured actual voltage at the PM contacts and entered the value in MP (the calc. divider showed some 500+ value), I didn’t entered actual current so maybe it is an issue as well?
Is it possible that I ran out of battery?


What motors? 400kv isn’t enough information. You don’t have to calibrate current but the voltage calibration isn’t close to being right.

For Vcc to be that low the battery would have to be almost dead flat. Who know because the PM isn’t calibrated.

Clipping occurs when the accelerometers hit full scale. It’s a cumulative metric the way it’s logged. An occasional occurance maybe from wind or high speed maneuvering isn’t a big deal but if it’s caused by vibration it’s a problem.

@dkemxr motors are GARTT ML 5008 400KV 6S.
Battery was empty, I just connected it to my charger and all cells varied from 2.97 to 3.2.

By mentioning PM calibration - do you mean setting the actual voltage and current and letting MP calculate the dividers?

As a side note, I started removing the electronics from the frame and it seems that the frame is a total loss :frowning:, the plates of the frame got twisted.


With cell voltages that low now under load it would have been lower. So yes, you drove that battery way too low.

Sorry for the reply, I meant you don’t have to calibrate current but voltage is very easy to do. Measure it and enter the value, done. The calibration of amps/volt for current can be done by logged vs charged mah and change the value to suit. It’s ratiometric.

@mboland hope you don’t mind me asking what software produces those nice log graphs?

Mission Planner is good for setups and mapping, but APM Planner is the graph king.

1 Like

@mboland @dkemxr Thank you so much for all the help