Crash Investigation Help

Hello, I have been trying to get an Ardupilot wing for quite some time and have been having many issues. After having a very large crash earlier today the plane now is completely destroyed so I would like to figure out what went wrong

From what I remember I flipped the wing into loiter mode and it increased throttle and began to circle before nose-diving down I tried to go back into flybywireA but it was too late had already slammed into the ice at around 90m mph :(. luckily I was able to recover the SD card so maybe someone can help me out with this.

(https://drive.google.com/file/d/1Zq3UyyydoYJsvvD7LgPWcCq4Yts_AlBo/view?usp=sharing)


it looks like you lost the right elevon before it lost control, you can see it trying to give max right elevon as pitch and roll diverge from wanted values.
normally that means a servo or more lightly a linkage failed.

2 Likes

I was just coming back in to say more or less the same as @geofrancis .

I would also add that there was either a trim or C of G issue with the wing.

Once the plane was in flight the control surfaces spent the majority of their time above the neutral position. You can see the right elevon hit max deflection several times after about mid-way in the flight. This might have been the stress point, or maybe when something moved in the plane.

3 Likes

thre are some really strange things in the parameters.

servo8 range is 1150-2000
servo8_trim is 1540

servo9 range is 1200-2100
servo9_trim is 1825 this is very high!

my guess is rather than mechanically centring your servos and trimming your control surfaces you have tried to compensate for bad servo setup with lots of corrections.

2 Likes

Yea I agree, had been having issues with the right servo for the past couple days so I “fixed it in software” and it worked for a couple of flights then I bet the servo stalled or failed as someone mention above. Thanks for the help

2 Likes

I think your both right looking back on it I had been having issues with the right servo before I couldn’t get it to trim correctly without redoing a lot of work I was too lazy to do, so I tried “fixing” it in software which for a couple of flight but obviously came back to bite me, Anyway thanks for the help greatly appreciated.

your servo probably finally let go, if it was loosing position then it was probably the potentiometer in the servo that had started to fail.

1 Like

Feeling real bad for this crash, but can you be specific in which servo used. Maybe we all can very very carefully in choosing for a new build.